GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1
    Newbie
    Join Date
    Jun 2011
    Location
    Novato, California, United States
    Posts
    5

    Default Wipers won't stop or run in intermittent mode when wet?!!!

    Weird issue here. I have a 1993 1500. When it is raining, I have an issue with my wipers where once I've turned them on, they will run at normal speed when the selector is on the intermittent mode, and even if I turn the selector to off to turn the wipers off, they'll still keep running for a while! I'm not certain that it isn't the switch mechanism on the turn signal wand, but the wipers do not behave this way when it is not raining. I can use the wipers to clean the windshield and run them on high, normal and intermittent mode and the control works as expected - and when I turn them off, they turn off. It seems to only occur when it is raining. So it seems that moisture is getting into some part of the electrical mechanism that controls the wiper functions from outside and/or in the engine compartment. I've not found any issue of moisture inside the cab at all.

    Any thoughts? I'd hate to replace the switch assembly on the turn signal wand (expensive) if that ends up not even being related to the issue....

    Thanks in advance!

  2. #2

    Default

    The most common wiper problem on those trucks is cracked solder joints on the circuit board. Remove the cover from the wiper motor to reveal the board. You can pop the board out easily and take a good, hard look at the solder joints where the connector terminals are attached. You may need to use a magnifying glass to see it. Take a good soldering gun and re-melt the solder on those joints, you probably won't even need new solder. Reinstall the board and see if that hasn't fixed it. The whole process takes about 10 minutes, and it fixes 90 plus percent of wiper problems on those trucks.
    Good Luck and God Bless

  3. #3
    Newbie
    Join Date
    Jun 2011
    Location
    Novato, California, United States
    Posts
    5

    Default

    Thanks a mil for the post! Will check that out here short - ly. Get it? *ahem*....

    ---------- Post added at 10:43 AM ---------- Previous post was at 10:02 AM ----------

    Definitely were cracks where the main connector is soldered to the board. Three out of the 5 had easily noticeable cracks in the solder completely encircling the connector post. I've re-soldered the 5 posts and am hoping this has resolved the issue! Thanks for the pointer - as well the cover doesn't seem to be very water tight, so I'm putting a little seal on it to see if that as well keeps humidity out of the box.

    Thanks again!

Similar Threads

  1. Uncontrollable intermittent wipers
    By kirt8548 in forum Chevy Truck Tech Forum
    Replies: 7
    Last Post: 08-31-2011, 04:50 PM
  2. Wipers won't stop - 2003 Suburban Z71
    By ajaxajax2000 in forum GM Electrical Tech
    Replies: 13
    Last Post: 04-21-2010, 02:11 PM
  3. intermittent no start
    By sagags in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 7
    Last Post: 01-20-2010, 09:22 PM
  4. Intermittent Grinding
    By KC8QVO in forum GM Powertrain
    Replies: 4
    Last Post: 12-15-2009, 09:27 AM
  5. window wipers stop sometimes
    By Davandy in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last Post: 02-21-2007, 03:30 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •