GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2
  1. #1

    Default Completely forgot about this site!

    Hello everybody. I guess I am sorta "new," even though I did technically create my account over 2 years ago. I was digging through some old links and found one to the site (well, at least through the old URL).

    So here is is my late, but "formal" introduction! I have a 2006 GMC Yukon Denali, fully loaded, currently has just under 15k miles. You can see my basic mods below, and it should hopefully stay that way... for now.

    I'll get some better pics later, but this was just after I had washed it. You can see the rest of the pics with the link in my sig.


    2009 GMC Sierra Denali AWD

  2. #2

    Default

    Welcome to the site! Glad to have you become active. The site's changed a lot in the last 2 years, that's for sure.

    Steve
    10 Chevy Traverse LT AWD
    02 Chevy Trailblazer LS (110K+ miles - loaded except for 4WD - WRECKED!)
    99 Chevy Cavalier LS (105K+ miles - commuter car)
    78 Chevy Suburban Silverado (454, 3/4 ton)
    62 GMC 3/4 ton Pickup (350 police interceptor)

    Remember: Search Before Posting | Fill out Your Profile & Signature
    Follow Us Please: facebook.com/gmtruckclub | twitter.com/gmtruckclub
    Support GMTC: Help the site, contribute today

Similar Threads

  1. Completely off topic, but I'm aggravated!
    By chevygurl in forum The Coffee Shop ~ Chit Chat
    Replies: 17
    Last Post: 03-06-2009, 03:49 PM
  2. Forgot to say Hi... How Rude!
    By whutdidyousay@yahoo.com in forum Member Introductions
    Replies: 8
    Last Post: 01-23-2009, 01:12 PM
  3. Completely shaved, two tone Yukon
    By Copper&Black in forum Photo & Video Gallery
    Replies: 17
    Last Post: 12-15-2008, 06:25 AM
  4. forgot to do my intro when i joined
    By chriskelley2003 in forum Member Introductions
    Replies: 6
    Last Post: 04-10-2008, 03:07 PM
  5. Forgot to put in Y-pipe donut
    By MD4x4 Fireman in forum General Chevy & GM Tech Questions
    Replies: 5
    Last Post: 02-03-2008, 12:12 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •