GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1

    Default Whine/whistling from engine compartment driving me nuts...

    I posted this information a few days ago in the Silverado/Sierra forum -- with no results/information gleaned. I'm hoping that by re-posting among those who read the powertrain forum that I might reach both a broader audience (more than just trucks) but also a more focused group (folks who concern themselves with the powertrain).

    Note that I did a search on 'whine' before posting this and found nothing I could immediately use, hence the need to post. (And yes, I read every result.)

    My 2004 GMCSierra1500 has had a (non-electrical in nature) whine/whistle in the engine compartment since I purchased it (used). It seems to be throttle-related in some way, as it manifests both when in motion as well as when parked. It happens most-frequently under the following conditions/circumstances:
    • When parked and I goose the gas pedal to bring it from idle to ~1500-2000 rpm. The whine manifests as the engine begins to rev up ... and falls away (after 0.5 to 1 seconds) as it reaches into the rpm range I just specified.
    • When under way and I am accelerating, the whine manifests frequently (for 0.5 to 1.5 seconds) in the ~1000-1250 rpm range of each gear just before it shifts. The whine falls away after the shift and may (or may not) reappear in the next gear.
    • When under way and I am decelerating, the whine manifests as the truck downshifts. I have yet to peg this to a specific rpm range and/or duration since I'm usually too busy paying attention to whatever has me decelerating.
    Of those circumstances it seems to happen mostly when I'm under way ... but I attribute this to the fact that I'm not usually mashing the gas when the transmission is in park!

    I have the sense that the position of the gas pedal is playing into this in some way ... but am not sure. I say this because when accelerating the noise appears to be most common when I'm steady on the gas for a reasonble take-off (i.e. it's not floored but I'm also not intentionally lagging). I got an even stronger sence of this when I noticed the problem manifested while parked -- when I was goosing the gas pedal to see if it'd make the sound I'm hearing.

    I am going to recruit a friend to help me diagnose the origin of the sound ... but I'd really like to know points under the hood that I should check -- given the symptoms I've described. I'm an engine newbie -- however I have a manual, a mechanical aptitude, and some time.

    Any help/insight on what/where to check would be appreciated.

    Surreal

  2. #2

    Default

    Have you checked all the air hoses and what not from the throttle body to the air intake? Maybe something is just lose or something is not completely sealed and some air is getting out. That would make a whistling noise for sure, and when you give it more gas the air is being forced into the throttle body at a more rapid rate so it might not escape as much hence the sound going away.
    Dave V. -- Riverside, California
    Owner of --
    2008 Chevrolet Silverado 1500 4.8Liter V8 engine 2WD w/Kenwood Double DIN CD/DVD Player
    1971 Chevrolet Chevelle 350ci V8 engine with 500+ horsepower (Still Under Construction)

  3. #3

    Default

    I'll give that a go this weekend. Thanks!

  4. #4
    Sr. Engineer
    Join Date
    Oct 2010
    Location
    Indianapolis, In
    Posts
    493

    Default

    I would second what hotrod has mentioned. Sounds as though it may be a vacume leak causing you problems. The fact that it occurs when accelerating and decellerating but not at a steady throtle seems a bit odd to me as vacume levels change from one side of the plate under those conditions. But as others here would say "if you here hoof beats, look for horses first then zebras". Start with air leaks.
    Good luck and let us know what you find.
    2000 GMC YUKON SLT, 5.3L tow pkg, G80 rear/w 3.73 gear

  5. #5

    Default

    This got more interesting last weekend when I took a Predator to the system and slapped the 87 octane tune on it. As soon as I did that the truck wouldn't idle -- at all. It'd hover at 500rpm and then drag to 300rpm and either die or recover. If it recovered it'd idle back up to 500 and then fall immediately. When I got the truck in gear quickly enough to go somewhere before it stalled it would nearly stall out at lights and when accelerating the whine/whislte was more pronounced than ever.

    I restored the original factory backup and the problem did not abate, so I dug in and did some research and learned that others who ran into this had other issues going on that caused the behaviour. Chief among these were a dirty/bad MAF sensor, dirty throttle body, bad/dirty EGR valve, and any number of vacuum leaks (hose to EGR valve, intake manifold, etc.). I'm currently working through the laundry list of things to do/check. This one's going to take some time, but it'll be worth it, as I'm pretty sure I'm getting atrociously bad gas mileage due to whatever's wrong.

  6. #6

    Default

    Problems resolved.

    * I search for and failed to locate a vacuum leak
    * The MAF sensor was, indeed, a mess, so I cleaned it thoroughly, too.
    * The throttle body was also a mess, likely thanks to the previous owner using too much oil on the CAI and failing to let it dry properly ... so I cleaned it thoroughly, too.

    I reassembled after cleaning and the found idle had perked back up. For whatever reason the whistling sound disappeared too.

Similar Threads

  1. Whining from engine compartment -- driving me mad and need ideas on where to look...
    By SurrealOne in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 2
    Last: 09-13-2011, 11:41 PM
  2. noise in engine compartment
    By feb in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 4
    Last: 08-19-2011, 10:05 AM
  3. Dropped in Engine Compartment!
    By amos1 in forum General Chevy & GM Tech Questions
    Replies: 3
    Last: 02-10-2010, 09:51 AM
  4. Carbon Build-Up In Engine Compartment
    By TRPLXL2 in forum General Chevy & GM Tech Questions
    Replies: 13
    Last: 12-30-2009, 08:35 PM
  5. Cables from Engine compartment to cab interior????
    By DT2007 in forum Audio, Video & Gadget Tech
    Replies: 0
    Last: 10-20-2008, 06:49 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •