GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6

Thread: silverado 03'

  1. #1

    Default silverado 03'

    Started truck this morning and volt gauge pegged all the way right. read it may reset if take off battery cable. Did that and replaced cable, started truck , gauge still pegged but truck now running like crap ! Help !!!

  2. #2

    Default

    Welcome to the club. A bad alterater can OVER charge a system. Can you get your truck to a AutoZone and have the alternater checked?
    :cool:

    2005 Chevy Silverado Z71 Crew Cab
    6" Skyjacker lift w/Edlebrock dual front remote resoviour shocks, single rear remote. Rancho skid-plate.
    17" x 9" M/T Classic Lock Wheels, 35" BFG A/T or M/T tires
    4.10 PercisionGears w/factory locker, T/A Performance rear-end cover
    Banks CAI intake, ported throttlebody, JBA coated headers, over-sized Magnaflow cats, Magnaflow cat back exhaust, Diablo tuned
    B&M aluminum deep transmission pan
    Warn brush guard w/Warn 9.5 XP winch, PIAA bulbs, Line-X bedliner, AWS Black tool chest, Extang tonneau cover
    Weather Tech floor mats
    Cover-Craft seat covers
    Dash mat cover
    Formula One window tint
    One black Lab in rear seat.
    :glasses:

  3. #3

    Default

    Hey , thanks for responce. Took it to autozone yesterday and everything tested fine, ( Alternater, battery,starter. ). But the guy said that battery test could be a lie due to fact that it is warm so I am on the way to take it cold (out of truck) to have it tested again ! Will post results !

  4. #4

    Default

    Quote Originally Posted by trinut3 View Post
    Hey , thanks for responce. Took it to autozone yesterday and everything tested fine, ( Alternater, battery,starter. ). But the guy said that battery test could be a lie due to fact that it is warm so I am on the way to take it cold (out of truck) to have it tested again ! Will post results !
    If the Double Check of the Battery turns out to be OK......then the Problem is most likely with the Stepper Motor for the Alt. Gauge is going Bad/Out.....which is A Common Problem on the 2003" to 2005" Trucks/SUV's Dash Cluster's.

    MIKE


    99"SILVERADO
    5.3 l 3.73 l G80
    BLACK BEAR CUSTOM TUNE
    SNUGTOP l COLORMATCH l KATZKIN










  5. #5

    Default

    Well, had battery checked out of truck and its in great shape. Put it back in and Big Red runs fine, Gauge is still pegged. Autozone cant give me an answer so I am turning to the Heartbeat of America clan. Any ideas and am I safe to drive ?

  6. #6

    Default

    Quote Originally Posted by trinut3 View Post
    Well, had battery checked out of truck and its in great shape. Put it back in and Big Red runs fine, Gauge is still pegged. Autozone cant give me an answer so I am turning to the Heartbeat of America clan. Any ideas and am I safe to drive ?
    Your safe to drive your truck, you can replace and/or have the stepper motor for the Alt Gauge.

    MIKE


    99"SILVERADO
    5.3 l 3.73 l G80
    BLACK BEAR CUSTOM TUNE
    SNUGTOP l COLORMATCH l KATZKIN










Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •