GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1
    Master Mechanic
    lancer's Avatar
    Join Date
    Aug 2009
    Location
    Farmersville, Illinois, United States
    Posts
    611

    Default Service engine code 174

    hey guys went and got gas tonight and went to walmart. when we came out started the truck to leave and soon as i put it in drive the service light came on. we took it to autozone to use their free scanner and it said 3 codes 171 and 174 twice. the print out they gave me says lean bank on one and two and MAF sensor. hasn't anyone else had this trouble?? its a 2002 tahoe 5.3 vortec flex fuel. i called the local autozone and they have one sensor instock for $80 with a $60 core with a year warranty. my question is should i go buy the new sensor and try it or take it to the shop and see what they have to say???


    2002 Tahoe LT---------TINTED WINDOWS------------7" DUAL DVD INDASH

  2. #2

    Default

    Quote Originally Posted by lancer View Post
    hey guys went and got gas tonight and went to walmart. when we came out started the truck to leave and soon as i put it in drive the service light came on. we took it to autozone to use their free scanner and it said 3 codes 171 and 174 twice. the print out they gave me says lean bank on one and two and MAF sensor. hasn't anyone else had this trouble?? its a 2002 tahoe 5.3 vortec flex fuel. i called the local autozone and they have one sensor instock for $80 with a $60 core with a year warranty. my question is should i go buy the new sensor and try it or take it to the shop and see what they have to say???
    For Both Trouble Codes.....P0171 and P0174.........may mean that one or more of the following has happened:


    • The MAF (Mass Air Flow) Sensor is dirty or faulty. Note: The use of "oiled" air filters may cause the MAF to become dirty if the filter is over-oiled. There is also an issue with some vehicles where the MAF sensors leak the silicone potting material used to protect the circuitry.
    • There could be a vacuum leak downstream of the MAF sensor.


    Edit.....A Cleaning of the MAF Sensor with......CRC's MAF Sensor Cleaner.....the 1 in the Silver Can......is most likely going to Correct the problem.







    Last edited by 99'HEARTBEAT; 10-20-2011 at 07:50 PM.

    MIKE


    99"SILVERADO
    5.3 l 3.73 l G80
    BLACK BEAR CUSTOM TUNE
    SNUGTOP l COLORMATCH l KATZKIN










  3. #3
    Master Mechanic
    lancer's Avatar
    Join Date
    Aug 2009
    Location
    Farmersville, Illinois, United States
    Posts
    611

    Default

    thanks 99heartbeat i'm going to try and get some maf sensor cleaner tomorrow and trying cleaning it before i replace it. also found a friend that has an actual code scanner so we are going to run it tomorrow night..

  4. #4

    Default

    Quote Originally Posted by lancer View Post
    thanks 99heartbeat i'm going to try and get some maf sensor cleaner tomorrow and trying cleaning it before i replace it. also found a friend that has an actual code scanner so we are going to run it tomorrow night..

    Let us know what happens......also take your time and be careful when cleaning the MAF Sensor, as it can be easily Damaged.....

  5. #5
    Master Mechanic
    lancer's Avatar
    Join Date
    Aug 2009
    Location
    Farmersville, Illinois, United States
    Posts
    611

    Default

    i took it to the car lot we bought it from yesterday morning and my buddy mechanic that works there scanned it and said it could be a few different things but not to worry about it. he cleared off the code and said if it comes back on bring and they'll look alittle harder. i cleaned the maf sensor with the cleaner when i got home. didn't look too bad but i don't know what a really dirty one looks like. we drove it 3 hour round trip last night and the light never came back on so i'm hoping it was just a fluke code and won't have anything to worry about...

Similar Threads

  1. Replies: 121
    Last: Today, 07:24 PM
  2. error code: service brake system?
    By DSpivey in forum Lifted & Offroad Suspension
    Replies: 0
    Last: 12-07-2010, 10:05 AM
  3. service engine soon code
    By cthegney in forum General Chevy & GM Tech Questions
    Replies: 3
    Last: 01-15-2010, 07:41 PM
  4. New Guy, Service code question
    By jedepsub in forum Member Introductions
    Replies: 9
    Last: 11-30-2009, 03:32 PM
  5. Service Engine Code
    By BajaMark in forum General Chevy & GM Tech Questions
    Replies: 9
    Last: 07-08-2008, 12:28 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •