GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1

    Default idles but thats it..

    I'm a newbie here and in need of some advice. I'm at wits end. I have a '94 K1500 that I've had since '97 and have done all the work on her that she ever needed. (So far.) Over the past few days it began so "slow down." I mean I needed to give it more throttle to get up to speed. I noticed the throttle body giving the "throaty sound" just coming up to cruising speed on the freeway. Then it happened. Full throttle gets me 50mph on a good day. It was time for a tune up so I threw the norm: Plugs, Wires, Cap , Rotor, and PCV. All Delco parts. She'll idle but as soon as those butterflies open it wants to misfire. I had an issue with the TPS before so I bought one just for kicks. (AC as well.) No luck. So far I've checked temperatures on exhaust manifolds as well as the cat to see if it's plugged. Temps looks normal. It appears to have enough fuel but I haven't yet put a gauge to the pump. Does anybody have any ideas to throw in the mix? What's confusing is that it idles smooth. Doesn't shake, doesn't miss, just smooth. I'm lost. Any help would be appreciated.

  2. #2

    Default

    You asked for ideas... Check for a clogged fuel filter yet? Maybe even the fuel pump? Possibly a hole in a fuel line?
    csltrains96
    Myself, my beautiful wife
    3 - boys
    3 - minivans
    1 - '89 Chevy K2500 Silverado Truck
    1 - 27 foot travel trailer
    Not enough family time!

  3. #3

    Default

    Changed the fuel filter and also found I don't have enough fittings to hook up my pressure gauge. (yet) Pump is running but will have to check pressure. I thought they either worked or they didn't.

  4. #4

    Default

    if the truck idles fine on a cold start, theoretically speaking, your pressure should be decent. not perfect, or fine, but decent. usually bad fuel pressure would cause a cold start to sputter or "miss". even though you replaced the tps, make sure it still works. using a multimeter, check resistence at no throttle, 1/4 throttle 1/2 throttle and so on to full throttle. the resistence values should change. also turn the key on a check that there is voltage going to the TPS. i want to say that it should be between 1.5 and 2 volts, but not for sure. double check the voltage values before taking my word for it.
    2002 Silverado K1500HD (NEW!!!!!!!)
    1999 S-10 Blazer
    1990 K1500 5-spd TBI 350.
    2001 Monte Carlo SS Pace Car

  5. #5
    Sr. Apprentice
    Join Date
    Jul 2010
    Location
    winnetka ca
    Posts
    53

    Default

    Timing?[ I put this in cause they said my message was to short]

Similar Threads

  1. 92 Suburban idles up and down then dies.
    By Daemon in forum Performance & Fuel
    Replies: 3
    Last: 05-08-2011, 07:17 PM
  2. Idles issues
    By k.daddy1 in forum GM Diesel & DuraMax
    Replies: 3
    Last: 04-29-2011, 12:47 PM
  3. 06 silverado Idles rough when cold
    By 6T7GOAT in forum GM Powertrain
    Replies: 1
    Last: 05-13-2010, 02:39 PM
  4. Idles Rough At Start-Up
    By mrcaddy in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 1
    Last: 01-11-2010, 03:46 PM
  5. idles wide open
    By T TOP TOM in forum General Chevy & GM Tech Questions
    Replies: 3
    Last: 08-17-2008, 06:26 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •