GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8
  1. #1

    Default Odd Cruise Control Problem

    2007 Suburban (1500, 2WD) Driving from Houston to Dallas today, and got on the highway early morning. With the cruise control on, I flashed my high beams and it disengaged the cruise control. Could not re-engage for a period of time (seems to me the sun was now up, and the headlights were off). Returning to Houston in the afternoon - engaged the cruise - hit the window switch - cruise control disengaged. Has anyone experienced anything like this in their vehicle - thanks for the advice in advance.

  2. #2

    Default

    That sounds like you're having some sort of computer malfunction. Cruise control, windows, and headlights on that generation are all computer controlled. If it were just when you flashed your high beams, I would suggest a wiring short in the steering column. It is still possibly, but less likely if your windows are causing the cruise to disengage. I would suggest taking a look at the wiring in the steering column to make sure everything is good there, and failing that you might end up having to go to a dealer for that type of problem.

    2008 FORD F350. My new all-around truck.
    2001 Silverado Reg. Cab Not-So-Base -- SOLD
    2003 Avalanche Z71. No Cladding. Check out my Mod thread. - Crashed. Will be rebuilt soon.
    1974 Triumph Spitfire 1500 - Work in Progress
    2003 Sierra 3500 Duramax. The Newer, Better Work Truck -- FOR SALE


  3. #3
    Legend
    Caddiac's Avatar
    Join Date
    May 2011
    Location
    Upstate South Carolina
    Posts
    2,045
    Blog Entries
    3

    Default

    If you could get the wiring diagrams you might be able to find a common denominator but I think pmf608 is on the right track.
    86 911 Porsche Carrera
    98 K1500 Suburban LT
    2012 Nissan Leaf

    ​General Motors.
    Because life is too short to drive a Ford

  4. #4

    Default

    Ever since I got my 1997 suburban k1500 about 1 and a half years ago, the cruise never worked. Then one day out of the blue "poof!!" it started working lol. It's been working for 4 months now and I have no clue why. I do know this model year of vehicle seems to have some issues regarding wires becoming coroaded and causing strange issues Ie: I'm dealing with a fuse issue right now on the rear passenger speakers/power door locks (hmmm what a strange combination to combine for a fuse block..lol) circut. Don't know if any of this is relevant to your issue but just letting you know from my limited observations and research, there is defiantly a trend on several forums regarding the above mentioned circuits...lol
    Last edited by truckfan4life; 11-07-2011 at 05:38 PM.

  5. #5
    Legend
    Caddiac's Avatar
    Join Date
    May 2011
    Location
    Upstate South Carolina
    Posts
    2,045
    Blog Entries
    3

    Default

    If we are talking weird behavior in the 97 - 98 I can write a book! The weirdness points to all of the following components: the multifunction switch, the cruise control module and the ECM. I have decided that since it works perfectly at times and not at all at others, it is probably not the multifunction switch. That switch was replaced once in the past for unrelated reasons. Basically what happens is it will not respond to the accelerate function which would indicated the switch were it not for the fact that it will cut off while going down the road. Or it will loose speed as it climbs a hill until it finally cuts off. If you "help it" with your foot, it will return to normal speed on flat ground. The only thing it does consistently is not be consistent.

  6. #6

    Default Cruise Control Rrratic Behavior

    My '96 had problems kincking out when accelerating or would not engauge. Took the control module off the firewall, disassembled and found the nylon gears severely worn. Ordered used one for a '97 off Ebay for about $50 and replaced the gears. No problems since . Tried to find just the gears without success. Easy repair.
    GBurb

  7. #7
    Legend
    Caddiac's Avatar
    Join Date
    May 2011
    Location
    Upstate South Carolina
    Posts
    2,045
    Blog Entries
    3

    Default

    I am going to check that out! Thanks for the tip.

  8. #8

    Default

    when it loses speed going up a hill then shuts off, that is an automatic default, and is the way it is supposed to function. in some vehicles, after losing a few MPH uphill, the trans will auto downshift, but that is not the way with most of the chevy's. it is supposed to shut off when it cannot sustain a minimum variance in speed.

Similar Threads

  1. Replies: 3
    Last: 12-03-2010, 06:40 PM
  2. Cruise Control Problem ?? Help
    By CarNut in forum GM Electrical Tech
    Replies: 0
    Last: 09-22-2010, 09:41 PM
  3. silverado 1500 cruise control problem
    By mitchlbuck in forum GM Powertrain
    Replies: 4
    Last: 02-28-2010, 11:19 PM
  4. cruise control
    By TheUnit in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 11
    Last: 12-29-2009, 08:21 PM
  5. Cruise Control??
    By imthatgirl in forum General Chevy & GM Tech Questions
    Replies: 2
    Last: 03-01-2008, 10:24 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •