GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8
  1. #1

    Default 1995 silverado run like crap !

    my 1995 silverado run bad it rolls over a long time before it starts and if you try to get on it, its like its starving for gas . changed the fuil filter but didnt help. need help bad thanx!!!! if the truck starts running bad i can shut it off and it will run better for a wile.
    Last edited by Bryanyager; 09-28-2011 at 06:57 PM.

  2. #2

    Default

    Welcome to the club. Is the check engine light on? Maybe the cat is plugged. '95 and older trucks don't have a rear O2 sensor to check the cat.
    :cool:

    2005 Chevy Silverado Z71 Crew Cab
    6" Skyjacker lift w/Edlebrock dual front remote resoviour shocks, single rear remote. Rancho skid-plate.
    17" x 9" M/T Classic Lock Wheels, 35" BFG A/T or M/T tires
    4.10 PercisionGears w/factory locker, T/A Performance rear-end cover
    Banks CAI intake, ported throttlebody, JBA coated headers, over-sized Magnaflow cats, Magnaflow cat back exhaust, Diablo tuned
    B&M aluminum deep transmission pan
    Warn brush guard w/Warn 9.5 XP winch, PIAA bulbs, Line-X bedliner, AWS Black tool chest, Extang tonneau cover
    Weather Tech floor mats
    Cover-Craft seat covers
    Dash mat cover
    Formula One window tint
    One black Lab in rear seat.
    :glasses:

  3. #3
    Jr. Apprentice
    Join Date
    Apr 2011
    Location
    Lumberton, TX
    Posts
    19

    Default

    Could be as simple as a clogged air filter. Assuming it is good, do you smell gas in the exhaust or anything? Does it only start slow after it has been sitting for a while or every time you start it? Does it idle rough?

  4. #4

    Default

    no cat on truck and no check engine light and it idles fine and dont smell gas in the exhust.
    Last edited by Bryanyager; 09-28-2011 at 07:05 PM.

  5. #5
    Newbie
    Join Date
    May 2009
    Location
    Destrehan, La.
    Posts
    2
    Blog Entries
    1

    Default

    You could be losing fuel psi i have a fuel pump that was sucking air in the tank the fuel line hose between the pump and the metal line. Also check the wiring at the pump they will miss upand short out

  6. #6
    Jr. Apprentice
    Join Date
    Apr 2011
    Location
    Lumberton, TX
    Posts
    19

    Default

    That could also be an injector issue or a bad gas issue. run some sea foam through and see if you get any change. With gas prices being the way they are, it is easy to get bad gas cause it's cheap. And it's not just us doing it, the stores are buying the cheapest gas they can get too.

  7. #7
    Newbie
    Join Date
    May 2009
    Location
    Destrehan, La.
    Posts
    2
    Blog Entries
    1

    Default

    there are a few things that will make it run like that throttle position sensor, the IAS, crank sensor, O2 sensors, fuel injectors, also check the wiring between map sensor and the throttle position sensor. i have a 90' and 92' that had the same problem.

  8. #8

    Default thanx for the replys

    I replaced the fuilpump assembly and it fixed it all !!

Similar Threads

  1. What is the BEST way to get this crap off?
    By Jimmeh in forum General Chevy & GM Tech Questions
    Replies: 6
    Last: 04-26-2011, 06:01 PM
  2. Holy crap!
    By z3ro in forum The Coffee Shop ~ Chit Chat
    Replies: 4
    Last: 03-22-2010, 08:24 AM
  3. crap!
    By capt sensible in forum Audio, Video & Gadget Tech
    Replies: 3
    Last: 09-26-2009, 06:48 PM
  4. Crap Tranny
    By sonomanick in forum Chevy S10 Forum (GMC Sonoma)
    Replies: 1
    Last: 07-21-2009, 10:04 PM
  5. Funny crap
    By Cableguy in forum Photo & Video Gallery
    Replies: 0
    Last: 12-18-2007, 09:05 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •