GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2
  1. #1

    Default 2004 C1500 Suburban

    With the 5.3L Vortec, two wheel drive. Its makes a squealing noise that starts when the truck starts and increases in intensity as more power is applied. We have checked/change the idler pullies, next idea was the power steering pump, but with the belt disconnected it still makes the noise. We are stumped and need help. Itís never had any problems before, don't know what caused this.


    Thanks Guys in advance.

    Leo

    First Post by the way.

  2. #2

    Default

    Is it a metal on metal squeal or does it sound like rubber squealing? You said that without the belt on it still squeals, does yours have two belts and if so were both removed?
    Gary

    99 K 1500 Suburban
    78 Silverado Big 10 w/factory 454
    00 S-10 Blazer
    1976 Trans Am
    1980 Honda CB900 Custom

Similar Threads

  1. Replies: 0
    Last: 04-04-2010, 03:00 PM
  2. 99 c1500 5.7 suburban missing at idle when hot
    By i_build in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 3
    Last: 10-22-2009, 06:08 PM
  3. Replies: 0
    Last: 08-05-2009, 02:40 PM
  4. 1993 C1500 Suburban FS
    By kknobl in forum General Classifieds
    Replies: 0
    Last: 10-24-2007, 08:52 PM
  5. For Sale 92 Suburban C1500 Silverado
    By DuneOH in forum General Classifieds
    Replies: 1
    Last: 06-07-2007, 06:51 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •