GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3

Thread: What's wrong??

  1. #1

    Default What's wrong??

    Ok straight to the point.. I bought a new battery for my truck.. Now 2 months later.. Just out of the blue when I go to start the truck it's dead... I jumped it off and drove it... A week later it does it again.. Took the battery off had it tested and it was so far gone that they couldn't even get the machine to work on it.. I got a new battery from them and he told me I needed the alternator checked.. Pulled the alternator off checked it and it was good. So I hook it all up with the new battery and my voltage meter isn't working and the cluster lights and climate control lights stay on even with the key out.. I know they have a delay in them but they never turn off.. What's going on? I pulled the neg cable off the battery so the lights didn't run it down while the truck sits.. Idk what's up..

  2. #2

    Default

    Did you remember to reconnect the voltage regulator on the alternator?
    ...
    ....

  3. #3

    Default

    Yes I hooked everything back up.. GM has a recall on the 04 clusters so that maybe why the voltage meter isn't working now... I got the lights on the dash going off now.. Idk what I did but it worked ha ha.. Had a guy come out and look at it and the truck is pulling alot of power from the battery even with the key out... He went thru the fuses and noticed it was the radio pulling more than it should.. It's aftermarket so idk... I pulled the fuse for it so it didn't pull any power what so ever until I get it out of the truck to replace it! Ah money money money
    Last edited by 04bowtie; 11-26-2011 at 04:03 PM.

Similar Threads

  1. what's wrong any help
    By killarag in forum GM Powertrain
    Replies: 4
    Last: 09-29-2010, 03:28 PM
  2. Could there be something wrong?
    By 1slols1 in forum Performance & Fuel
    Replies: 2
    Last: 11-30-2009, 05:58 PM
  3. Did I do something wrong??
    By blackburb in forum Lifted & Offroad Suspension
    Replies: 7
    Last: 09-21-2009, 08:59 PM
  4. How wrong was I?
    By Kady in forum GM Powertrain
    Replies: 29
    Last: 03-17-2009, 09:09 PM
  5. What could be wrong with my 4x4
    By mike54 in forum GM Powertrain
    Replies: 2
    Last: 12-22-2008, 08:41 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •