GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 LastLast
Results 1 to 10 of 18
  1. #1

    Default Miss on 99 Suburban 5.7 Vortec 180K

    Ok, I just had my intake manifold gasket replaced that was leaking. Thanks for everyones input, I had this miss that started before it was fixed, when I notice it most is when I floor it or hit the highway cruising along. It's like for a fraction of a second the engine has a miss are no power, like the spark was turned off or a jerk. Could this be the injectors ( ran injector cleaner already ), ignition, no codes come up or service engine light. The map sensors had been replaced by the other owner, but I have one of those K&N type air filters in the intake box. Any thoughts, new plugs installed 500 miles ago.

  2. #2

    Default

    hmmmm... no code yet? Have you checked the line to the intake butterfly to make sure it isn't hitting something at WOT?
    I like you.

  3. #3

    Default

    Check the fuel pressure. These trucks need to have at least 60 psi at all times or you will experience all kinds of drivability problems including hesitation and misfires.

    97 Chevrolet Suburban K1500 5.7L
    78 GMC High Sierra K1500
    Fat, drunk, and stupid is no way to go thru life.

  4. #4
    Legend
    Caddiac's Avatar
    Join Date
    May 2011
    Location
    Upstate South Carolina
    Posts
    1,987
    Blog Entries
    3

    Default

    Could be a sticking injector. Don't Worry, it will tell you if there is an issue that the ECM cannot control.
    86 911 Porsche Carrera
    98 K1500 Suburban LT
    2012 Nissan Leaf

    ​General Motors.
    Because life is too short to drive a Ford

  5. #5
    Jr. Apprentice
    Join Date
    Oct 2011
    Location
    South portland, Maine
    Posts
    23

    Default

    I have a 97 K2500 with the 5.7 vortec and I am having the same issue. I have had the truck about 6 months and have not had a chance to really investigate yet. If I find anything I'll post....Wayne

  6. #6

    Default

    Im tracing a similar issue and think that I have it nailed down to a corroded distributer cap. No mechanic here, but going through the process of elimination and it led me to pulling the distributer cap and found it unpleasant looking.

    99 GMC Suburban 5.7

  7. #7
    Legend
    Caddiac's Avatar
    Join Date
    May 2011
    Location
    Upstate South Carolina
    Posts
    1,987
    Blog Entries
    3

    Default

    Good catch! That sucker will run fine until one day and boom! It will skip like heck. Got me coming back from the coast. Long drive skipping - LOL. Be careful tightening the screws! The distributor ears are plastic and break easily.
    86 911 Porsche Carrera
    98 K1500 Suburban LT
    2012 Nissan Leaf

    ​General Motors.
    Because life is too short to drive a Ford

  8. #8

    Default

    Still having the problem, took out the K&N type filter, back to paper and cleaned the MAF sensor with the CRC cleaner for MAF. The prior owner had changed it before. Today I finally got a error code P0171 bank one too lean, have not replaced fuel filter yet, so with this error code any ideas to narrow it down?

  9. #9

    Default

    Have you checked the fuel pressure? My 97 would throw a lean or misfire code every once in a while and it turned to be low fuel pressure. Swapped in a new fuel pressure regulator and it solved the problem.

    97 Chevrolet Suburban K1500 5.7L
    78 GMC High Sierra K1500
    Fat, drunk, and stupid is no way to go thru life.

  10. #10

    Default

    Would it be a regulator with a bank 1 & 2 code? Could it be erg valve, bad injector, l changed fuel filter & ran GM Injector, still get the 171 & 174 codes
    Last edited by dhpgac; 12-17-2011 at 05:32 PM. Reason: update

Page 1 of 2 12 LastLast

Similar Threads

  1. 1997 Vortec 454 , very bad stumble and miss
    By jad3500 in forum Chevy C/K Truck Forum
    Replies: 2
    Last Post: 10-19-2011, 10:10 PM
  2. 94 suburban with a slight miss at crusing speed
    By bholmes80 in forum General Chevy & GM Tech Questions
    Replies: 6
    Last Post: 11-15-2010, 09:28 PM
  3. Shudder/ miss at idle 5.7 vortec
    By vicar75855 in forum GM Powertrain
    Replies: 6
    Last Post: 10-02-2010, 11:31 PM
  4. GMC SUBURBAN vortec,,problem HELP !!!!!!!!!!!!!! ?????
    By DAREDEVIL in forum General Chevy & GM Tech Questions
    Replies: 10
    Last Post: 08-10-2010, 12:21 PM
  5. 95 5.7 suburban a vortec engine or??
    By Z-burb in forum GM Powertrain
    Replies: 3
    Last Post: 02-25-2008, 10:32 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •