GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 7 of 7
  1. #1
    Sr. Mechanic
    kburb's Avatar
    Join Date
    May 2010
    Location
    Blythewood SC
    Posts
    191

    Default Cranking Issues - Please Read

    Got a 2k10 2500hd with a 6.0 gas motor. Every now and then it wont crank, kinda random and no hint or clue when it will happen again. Here is what happens.


    I switch the truck and do wha ever and when i go to crank it will sputter then die or just spin like its not getting a spark or fuel. If you wait 45 mins to an hour it will crank right up and run like a top, no check engine light or nothing. I have taken it to the dealer and the only thing they could figure was the fuel pump had a short and replaced it but it happend again friday night.


    Does anybody have any ideas or has had this happen?



    91 Suburban

    D44/14BFF w/Disc conv - Yukon 4:88's - Yukon Grizzly Lockers F/R -13" lift - DIY4x Shackle Flip - 37 ATZ on 18 MT Classics - Doug Thorley headers - Magnaflow - Holley Pro Jection Intake - Ultimate TBI mods - Hydroboost Brake Conversion - Hysteer-X Over Conversion.

    (Coming up - Fuel Injected 383 Stroker - Divorced NP205 - D60 - 40" tires)

  2. #2
    Sr. Engineer
    Join Date
    Dec 2011
    Location
    11-22-boogie woogie avenue
    Posts
    308

    Default

    Sounds just like a crank sensor.. have them scan it anyways ... even no light.

  3. #3
    Sr. Mechanic
    kburb's Avatar
    Join Date
    May 2010
    Location
    Blythewood SC
    Posts
    191

    Default

    Quote Originally Posted by dipstick View Post
    Sounds just like a crank sensor.. have them scan it anyways ... even no light.
    "Crank Sensor" when did engines get so electronic. thats why i own my 91 the only computer is for teh TBI and i can put it in the trash if it causes to much trouble.


    thanks for the advice i will get the to look at it next week

  4. #4

    Default

    I had a similar problem not too long ago, all that was wrong was the connections to the battery had come loose.

  5. #5
    Master Mechanic Jimmeh's Avatar
    Join Date
    Apr 2009
    Location
    Columbia Falls, Montana, United States
    Posts
    806
    Blog Entries
    3

    Default

    I am voting crank sensor as well.
    2005 Chevy Silverado W/T
    4X4|4.8 with some mods (has only slightly more pull than a 5.3)|Auto|4 door ex cab|Cooper Discoverer AT/3's in 285-75/17's on Helo 842's|Cooper Discover M+S 265-75/17's on Devino DV349's|Flowmaster 40 Single in Dual out with custom bent pipe from the end of the cats back|2" Procomp leveling kit|Custom made center console|Custom dyno tunes|Air Raid CAI|Air Raid Throttle Body Spacer|Apex brand topper|Kenwood Head Unit with Kenwood speakers|Painted mirrors/grille|Debadged except front emblem|Bilsteins front and rear
    Planned mods not in order
    2 inch lift|Custom front/rear bumper|hitch tire carrier|roof basket on topper, bars on cab|finish center console build|install Midland CB|Power options|Tint|Custom made raised bed in the bed of the truck|Lund LunarVisor
    Also have a 1992 Ford Ranger with a lot of stuff done to it. Currently waiting for a bit of a rebuild.


    "The only woman I'm pimping from now on is Sweet Lady Propane. And I'm tricking her out all over this town."

  6. #6
    Sr. Mechanic
    kburb's Avatar
    Join Date
    May 2010
    Location
    Blythewood SC
    Posts
    191

    Default

    Well it happend again, went to the tire store for a new set and when they brought out to me it wouldnt crank back up. there tech played for 20 or 30 mins looking at everything and ended up messing with a couple of relays and it cranked right up. Not sure if its a bad relay or it happen to to sit long enough. When he put the scanner on it no codes came up so still dont know if its fixed or not. Guess we will just have to wait and see.

  7. #7
    Master Mechanic Jimmeh's Avatar
    Join Date
    Apr 2009
    Location
    Columbia Falls, Montana, United States
    Posts
    806
    Blog Entries
    3

    Default

    Try moving a different relay to your starter location and see if that makes a difference. If it does, there is your problem.

Similar Threads

  1. Occasional very slow cranking
    By Johnny_Buchanan in forum GM Powertrain
    Replies: 2
    Last: 12-23-2010, 07:16 AM
  2. cranking up torsion bars?
    By Cuda1500 in forum Lifted & Offroad Suspension
    Replies: 2
    Last: 06-17-2010, 12:49 AM
  3. 2001 silverado constantly cranking
    By billbrown52dt in forum GM Powertrain
    Replies: 10
    Last: 05-06-2010, 10:59 PM
  4. 2002, cranking but won't start
    By 02trailblazer in forum Chevy Blazer Forum (GMC Jimmy)
    Replies: 7
    Last: 07-27-2009, 08:33 AM
  5. truck won't catch when cranking.
    By L0sts0ul in forum GM Powertrain
    Replies: 3
    Last: 03-17-2008, 08:21 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •