GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 3 of 3 FirstFirst 123
Results 21 to 22 of 22
  1. #21
    Jr. Apprentice
    Join Date
    Jan 2010
    Location
    West Texas
    Posts
    13

    Default

    Yes they do idle at 500 rpm. Idle is set by ecm. My 93 burb has be that way since I purchased 2 years ago. With the amount of miles on the burb chances are plugs and wires have not been done in a while.

  2. #22
    Sr. Engineer
    Join Date
    Dec 2011
    Location
    11-22-boogie woogie avenue
    Posts
    308

    Default

    Really glad it is fixed.... any time something quits ..trouble shoot saves a lot of time and money.

Page 3 of 3 FirstFirst 123

Similar Threads

  1. Replies: 0
    Last Post: 12-05-2011, 06:00 AM
  2. Hard Starting Suburban
    By GMC Burban in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 3
    Last Post: 11-20-2010, 04:20 PM
  3. 98 Suburban Starting Trouble
    By mounty95 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 3
    Last Post: 08-19-2009, 11:35 PM
  4. 97 Suburban Hard Starting
    By joecar in forum GM Powertrain
    Replies: 8
    Last Post: 01-09-2008, 07:21 PM
  5. 94 suburban starting problems,
    By lwick in forum GM Powertrain
    Replies: 1
    Last Post: 11-12-2007, 04:55 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •