GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 9 of 9
  1. #1

    Default 1999 Chevy 1500 oil pressure almost 80 psi at start up

    I just got my truck about two months ago. I noticed when the weather started to get colder that the oil pressure runs really high. It runs between 70 and 80 psi when i first start it and until the engine warms up to operating temperature. When it gets to operating temperature it runs just above 40 Psi. It is a 1999 chevy 1500 old body style with the 5.7 in it. I have not had a chance to change the oil it it yet so i am not sure the viscosity of the oil in it. I am going to change the oil next week and put 5w30 in it to see if that makes a difference. I was thinking maybe they were running a heavier oil in it and that is why the oil pressure goes down when it warms up. Does anyone have any other ideas or know of any issues this model may have had with oil pressure? Any advice would be great.
    Tony-1999 Chevy 1500 z71 4x4

  2. #2

    Default

    I would change the oil as soon as you can. Could be running straight SAE30 right now.

    1995 Silverado 4x4
    6" BDS Suspension Lift-3" Body Lift-Add A Leaf in rear -Trailmaster SSV Shocks-Duel Steering Stabilizer Kit -AirAid Cold air intake-
    4.56 Gears with Detroit Auburn Locker-Pro-Comp Traction Bars with duel shocks-Aluminum Skid Plate Kit-38.5" x 16.5" Mickey Thompson Baja Claws-Constant Dropping fuel gauge

    2005 Yukon XL Jet Power Programmer, Bilstein Shocks, Bilstein rear springs, Helwig Anti-sway bars, EGR Window Visors, EGR Hood Shield, Denali Headlights, Headlight harness upgrade, GE NightHawk Bulbs, White Night Rear lighting system, Russell Braided SS brake lines, PowerStop Brake pads, PowerStop cross drilled and Slotted Rotors, http://www.gmtruckclub.com/forum/sho...5-GMC-Yukon-XL
    2002 Silverado ext cab 2wd (Sold)
    2003 Yukon XL (Totaled)

  3. #3

    Default

    I changed the oil in my pickup today and put 5w30 in it and the oil pressure is still running high. My plan tomorrow is to hook in a mechanical gauge tomorrow where the oil pressure sending unit is to see if it is running normal with mechanical gauge. I was just wondering if anyone knows of any issues these pickups had with oil pressure or if maybe there is a oil pressure regulator in the system somewhere that i do not know about.
    Tony-1999 Chevy 1500 z71 4x4

  4. #4

    Default

    I unscrewed my oil pressure switch/sending unit, and put in a a mechanical gauge to get a actual reading. It was a lot closer to normal. The spec from a chilton manual is 8 psi at 1000rpm and 16 psi at 2000rpm and 24 psi at 4000rpm. mine was higher but with a mechanical gauge it is reading alot closer to what all the other people i know who have this style of pickup run. with the mechanical gauge i am reading about 28-30 psi at low idle about 800 rpm and at 2500rpm it is reading about 40-42 psi. I ordered a new oil pressure switch. I got it yesterday and i have to put it in yet to see if that cures the problem. i will put up another post when i get that in to see if it cures my problem.
    Tony-1999 Chevy 1500 z71 4x4

  5. #5

    Default

    I put in my new oil pressure switch today. The gauge in the pickup is still reading really high so it must be in the gauge. Which would involve the whole cluster so i think i might just run with it like it is or run a mechanical gauge. if any one has any ideas let me know thanks
    Tony-1999 Chevy 1500 z71 4x4

  6. #6

    Default

    the gauges usually read high and are even worse if you don't use a ac delco sender
    my 88 sas "mudwasp"
    88 chevy k2500, started as reg cab lb, now reg cab shortbox, sas 17'' of lift, 52'' front springs f.i. bbc , 79 dana hp 60 chevy outers, 14bolt ff spooled divorced 205 and cut 40'' gumbos
    1998 k3500 gmc crew cab dually L65 6.5TD 4l80e with a couple of mods

    bouncing truck avatar creator

  7. #7

    Default

    Has an Ac Delco Sender in it and they read high. Is it a big pain to replace the cluster and is the cluster expensive or is it just better off to leave it the way it is and maybe run a mechanical gauge to it.
    Tony-1999 Chevy 1500 z71 4x4

  8. #8

    Default

    Quote Originally Posted by chevy_truck_driver View Post
    Has an Ac Delco Sender in it and they read high. Is it a big pain to replace the cluster and is the cluster expensive or is it just better off to leave it the way it is and maybe run a mechanical gauge to it.
    The cluster is easy to change, you just pull the dash bezel and there should be 4 bolt holding it in place. Chances are they are pretty costly. You could always just change the stepper motor if you think that is the issue. If you search you tube there a videos on how to change the stepper motor out.

    1995 Silverado 4x4
    6" BDS Suspension Lift-3" Body Lift-Add A Leaf in rear -Trailmaster SSV Shocks-Duel Steering Stabilizer Kit -AirAid Cold air intake-
    4.56 Gears with Detroit Auburn Locker-Pro-Comp Traction Bars with duel shocks-Aluminum Skid Plate Kit-38.5" x 16.5" Mickey Thompson Baja Claws-Constant Dropping fuel gauge

    2005 Yukon XL Jet Power Programmer, Bilstein Shocks, Bilstein rear springs, Helwig Anti-sway bars, EGR Window Visors, EGR Hood Shield, Denali Headlights, Headlight harness upgrade, GE NightHawk Bulbs, White Night Rear lighting system, Russell Braided SS brake lines, PowerStop Brake pads, PowerStop cross drilled and Slotted Rotors, http://www.gmtruckclub.com/forum/sho...5-GMC-Yukon-XL
    2002 Silverado ext cab 2wd (Sold)
    2003 Yukon XL (Totaled)

  9. #9

    Default

    It probably isn't a stepper motor issue. I would suspect it is the driver that runs the motor which is part of the computer. The readings you are getting are not all that unusual. Factory gauges are rarely ever dead-on accurate. If you change the cluster, the odometer will not be correct and it probably won't fix the problem anyway. I would suggest to leave it alone. At least you know what the oil pressure on the gauge looks like and what those numbers really mean. If it changes, look at it again with your mechanical gauge. I would just drive it as-is. If you are uncomfortable with that, then you need a good mechanical gauge.

    Just my .02 and worth every penny you paid for it.
    "It went together didn't it? Well then there has to be a way to take it apart!" - Me.

    Check out my image gallery HERE.



    "The true measure of a man is how he treats someone who can do him absolutely no good." ~Samuel Johnson (1709-1784)

Similar Threads

  1. 1999 Chevy Suburban 5.7L 350 Vortec Won't Start
    By Leslie6900 in forum GM Powertrain
    Replies: 1
    Last Post: 04-10-2011, 02:17 PM
  2. 99 Yukon 5.7 No Oil Pressure Wont Start
    By Alaskan in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 1
    Last Post: 10-31-2010, 11:09 PM
  3. Replies: 42
    Last Post: 12-03-2008, 02:52 PM
  4. No start- low oil pressure
    By Andymi in forum GM Powertrain
    Replies: 6
    Last Post: 10-24-2008, 02:42 PM
  5. no oil pressure at start up...sometimes?
    By Smithd24 in forum GM Powertrain
    Replies: 8
    Last Post: 06-22-2007, 12:47 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •