GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12
  1. #11

    Default Baffled. And frustrated.

    [QUOTE=unplugged;39755]
    Good backpressure before the cat pretty much rules out a clogged cat. You say it doesn't have power under a load? What kind of load? Towing or just accelerating? Does it pull well at low speed, but not on ramp speeds?

    I have experienced a clogged cat and it wouldn't accelerate well with or without towing a load. Putting around town wasn't as noticeable, but merging speeds on a freeway on ramp was when it was most noticeable.

    You mentioned a 'howling' sound under load. Could point to a transmission problem. Smell any burnt almonds?



    It lacks power under typical acceleration. Not towing load. It does do better at lower speeds but when I got on the on ramp to the highway this morning when it went into the last gear and then lockup, it was terribly sluggish and yes when you accelerate there is a roar under the floor of the truck. Lots of vibrations at various (higher) speeds also. There's a shudder when it's in lockup also. The fluid is good. Full clean and not burnt. We checked the pressure from the cats...it was less than 2 psi. We've gone through a few engine issues. The fuel filter is less than 3 months old and changing it improved my gas mileage. The pressure from the pump is fine. The EGR valve is fine. The MAF sensor is fine. I find it hard to believe that it's an engine related problem. The truck starts and runs really good for having
    220K on it. So does anyone agree that having the transmission diagnosed first would be the right move? It's a cheaper choice I know that much.

    BTW... Wiscaaaaansin is just south of Canada dere eh? You norterners oughtta look at a map sometime..ya kno!?

    Thanks for the input.
    Dale Junior #88. A new era in the Earnhardt Legacy.
    GO JUNIOR!! :great:

  2. #12
    Master Mechanic TahoeFever's Avatar
    Join Date
    Sep 2007
    Location
    Now IN Auburn AL :)
    Posts
    533

    Default



    Sorry just had to throw this inn ..heheheh
    04 Tahoe LT 5.3L stock MSD 8.5mm Wires
    Gigbson Duels Straight Exhaust, Parrot 3100 Bluetooth
    K&N 77 Series CAI, Sirius Radio
    De-badged, Valet Dei remote start
    5000k HID -Higherlevelauto.com
    Federal 100watt air horn

Page 2 of 2 FirstFirst 12

Similar Threads

  1. New Member in S.E. Wisconsin
    By bparent in forum Member Introductions
    Replies: 9
    Last: 03-31-2010, 10:21 PM
  2. Noob from Wisconsin
    By Griffin1340 in forum Member Introductions
    Replies: 11
    Last: 02-19-2010, 11:23 AM
  3. new in wisconsin
    By hearseman in forum Member Introductions
    Replies: 10
    Last: 03-03-2009, 04:41 PM
  4. Greetings from wisconsin
    By THE STARGAZER in forum Member Introductions
    Replies: 8
    Last: 02-03-2009, 04:12 PM
  5. new guy from wisconsin
    By sniper24 in forum Member Introductions
    Replies: 6
    Last: 09-02-2008, 09:59 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •