GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Default 1995 chevy k1500

    purchased 95 chevy in alaska a few weeks ago, vehicle ran super rich and would die several times on my way back to base.
    i had to hold foot on gas to keep it running, when i changed spark plugs out there was only but a hair left on all of them.

    1995 k1500 4x4 5.7L TBI ***appears to have OLDER block*** when going to do oil change i noticed the filter was larger then suggested filter, 9 years ago i had an 86, looked about the same... so i went and purchased it and it matched up perfectly (old one was so ... old.. the label was almost unreadable)
    Things i've done - new spark plugs, new mass air flow sensor (was dieing, swapped that out on side of road, solved that)
    the engine was lightly ticking, but couldn't locate with a stethoscope, so i assumed maybe oil pump, changed oil and put in slick50 and noise went away, oil pressure wasn't reading right, shot wires and gauge was good, swapped sending unit and now receiving appropriate readings...
    the steering pump gasket was out, so going to replace that soon as it gets in, BUT it's been slinging AT4 all over the place... thinking maybe it's messing with my alternator...can see where it's flung up onto the bottom of it... maybe it's going out (thinking this due to slight engine RPM adjust when turning lights on, heater, going up or down with the electric windows...)
    Exhaust is pretty bad behind the CAT... idk if CAT is even any good anymore, not sure how to check that....(thinking chop it out lol)
    the rest of exhaust is sadly held together by bailing wire... it's on the list to fix, just want to get engine running smooth and at appropriate RPM... i took some carb / intake cleaner (b12) and sprayed into the TBI and it cleaned it up pretty well... but if i'm at low RPM... and petal to metal it will backfire though intake once... (timing is set mechanically, with computer unplugged) dont know if computer is off or what...
    i have a theory that maybe my alternator / coil / distributor might be the chain in which i'm having issues but to be honest i'm lost..

    just trying to think of some reasons as to why it wants to idle at 1500 instead of 1000... and sadly it's OBD1 and all i have access to is obd2 readers.
    it smokes pretty well too, just a white/gray... no mix in oil / coolant.. no detectable loss in the two either.
    Last edited by ossumpanda; 12-22-2011 at 10:31 PM.

  2. #2
    Sr. Engineer
    Join Date
    Dec 2011
    Location
    11-22-boogie woogie avenue
    Posts
    308

    Default

    Sounds like classic cts /coolant temp sensor beside thermostat housing... out of resistance ecm keeps feeding fuel for warm up.
    Never receives right info from cts. Should idle in the 600 to 800 range. Another sensor that will make it idle high is tps . Might be fuel regulator.
    Cts cost $10 get it out of the equation.

  3. #3

    Default update 1

    Quote Originally Posted by dipstick View Post
    Sounds like classic cts /coolant temp sensor beside thermostat housing... out of resistance ecm keeps feeding fuel for warm up.
    Never receives right info from cts. Should idle in the 600 to 800 range. Another sensor that will make it idle high is tps . Might be fuel regulator.
    Cts cost $10 get it out of the equation.
    Replaced both parts, no noticeable difference... BUT i did realize when i unplugged the brown wire with tan line (next to glove box) for adjusting timing... well when disconnecting that.. it idles perfectly... so does this mean my computer is jacked up?

Similar Threads

  1. 1995 Suburban k1500 High rpms no power
    By Drinkin380 in forum GM Powertrain
    Replies: 5
    Last Post: 05-16-2011, 06:25 PM
  2. upgrade frontbrakes K1500 1995
    By 2loud in forum Lifted & Offroad Suspension
    Replies: 0
    Last Post: 04-20-2011, 07:24 AM
  3. 1995 GMC K1500 5.7 running rough
    By tknucks in forum GM Powertrain
    Replies: 2
    Last Post: 02-03-2011, 01:55 PM
  4. For Sale: 1995 Chevy K1500 Regular Cab Stepside short box rarity
    By Xtrempickup in forum Chevy Trucks For Sale eBay
    Replies: 1
    Last Post: 02-03-2011, 08:10 AM
  5. Parting out 1995 k1500 suburban
    By skinut88 in forum General Classifieds
    Replies: 8
    Last Post: 01-25-2010, 11:01 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •