GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1

    Question Airbag light, blower not working on any speed

    OK,
    The Solenoid on my starter went just before going away from home. I disconnected the battery and left the truck for about a month. I just returned home and finished replacing my starter? Now my service air bags light is on (on dash and DIC) and my blower fan is not working on any speed? Is this related to the battery being disconnected for a month? I have not yet driven anywhere and it has gotten much colder since originally disconnecting the battery.

    Thanks
    Brown '07 Silverado LTZ V-Max

  2. #2

    Default

    i would check the fuses. in the manual for most cars/trucks it says to turn off all electrical systems before connecting/disconnecting the battery this is because when u reconnect the battery it can cause a surge that might blow one of the fuses. the blower is usally on its own fuse so it might of blown when the battery was reconnected. and airbag light is probly on because the airbag computer is confused because it had no power it should go away over time if not u just need to clear the code on the OBD

    1996 Chevy Tahoe LT 5.7L V8 4X4 205,000+ miles. Built proudly at Janesville Assembly in Janesville, Wisconsin
    Basic mods: Lights all over, bunch of electrical work, and a couple cooling mods.

    Check out my other mods in My Garage: http://www.gmtruckclub.com/forum/sho...t-Tahoe-4-Door

  3. #3

    Default

    Ok pulled fuses on both ABS and airbags, started and ran truck, refitted fuses and all OK?
    Brown '07 Silverado LTZ V-Max

  4. #4

    Default

    ok can u please elaborate. did u do what i said and it fixed it or did the problem still presist

    1996 Chevy Tahoe LT 5.7L V8 4X4 205,000+ miles. Built proudly at Janesville Assembly in Janesville, Wisconsin
    Basic mods: Lights all over, bunch of electrical work, and a couple cooling mods.

    Check out my other mods in My Garage: http://www.gmtruckclub.com/forum/sho...t-Tahoe-4-Door

  5. #5

    Default

    Just did what I said, pulled fuses, started truck, shut off truck after several minute, then replaced fuses. Hope it stays away.

    Thanks!
    Brown '07 Silverado LTZ V-Max

  6. #6

    Default

    no problem! glad to help

    1996 Chevy Tahoe LT 5.7L V8 4X4 205,000+ miles. Built proudly at Janesville Assembly in Janesville, Wisconsin
    Basic mods: Lights all over, bunch of electrical work, and a couple cooling mods.

    Check out my other mods in My Garage: http://www.gmtruckclub.com/forum/sho...t-Tahoe-4-Door

Similar Threads

  1. Airbag light
    By jonejam2 in forum General Chevy & GM Tech Questions
    Replies: 11
    Last Post: 02-27-2011, 04:55 PM
  2. Blower motor not working
    By lancer in forum General Chevy & GM Tech Questions
    Replies: 8
    Last Post: 06-28-2010, 05:18 PM
  3. Airbag Light
    By ahm1127 in forum General Chevy & GM Tech Questions
    Replies: 4
    Last Post: 03-22-2010, 10:52 AM
  4. Blower stopped working
    By engrsjp1 in forum General Chevy & GM Tech Questions
    Replies: 3
    Last Post: 09-25-2009, 02:00 PM
  5. air/heat blower not working?
    By gabronco91 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 7
    Last Post: 12-14-2008, 01:13 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •