GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 2 of 3 FirstFirst 123 Last Post byLast Post by
Results 11 to 20 of 27
  1. #11

    Default

    the dealership here isnt the only one that tells customers that, they extended the warranty by 25k miles. but its done it for 8-9 years now and nothings gone wrong with the motor so i believe em.

  2. #12
    Sr. Apprentice
    Join Date
    Nov 2011
    Location
    Shady Spring, WV
    Posts
    60

    Default

    I agree with CORSO, I thought that was a trait. My knocks of start up also. If the filter is not 2 stage (orange mostly) all oil drains back and allows knocking on start up. I have changed from the orange filter to GM or MOPAR and the knocking goes away. As a service manager, I called the factory hotline about a knock and they asked if it has an orange filter on it not to call them until I changed the filter and rechecked for a knock.

  3. #13

    Default

    Quote Originally Posted by grape2 View Post
    I agree with CORSO, I thought that was a trait. My knocks of start up also. If the filter is not 2 stage (orange mostly) all oil drains back and allows knocking on start up. I have changed from the orange filter to GM or MOPAR and the knocking goes away. As a service manager, I called the factory hotline about a knock and they asked if it has an orange filter on it not to call them until I changed the filter and rechecked for a knock.
    Interesting info regarding filter types, that is new to me. What is considered an "orange filter", a Fram? I just had my Silverado's oil changed last Tuesday at the dealer. I would think they are using AC Delco filters. Engine still knocks/clatters/whatever you want to call it upon cold start up.

    When I had my TBSS I did the oil myself always using Mobile 1 and Delco filters and it too did the same. My Suburban currently has a Delco filter in it and it makes all kinds of racket upon cold start up. The 2 454s I had in my Formula offshore boat always had either Mobile 1 filters or WIX filters, and guess what? You guessed it....knock on cold start up.

    Like I said earlier, a GM pushrod motor that does not knock upon cold start up is an anomaly. It's the nature of the beast.
    -2001 Suburban 2500 LT 8.1
    -2000 Silverado 1500 LT Z71

    Gone but not forgotten:
    -2007 TrailBlazer SS
    -2004 Cadillac CTS-V
    -1998 Silverado 1500 LT Z71
    -1989 Pontiac Formula WS6

  4. #14
    Sr. Apprentice
    Join Date
    Nov 2011
    Location
    Shady Spring, WV
    Posts
    60

    Default

    I have used Mobil 1 for years until I switched to Valvoline syn oil. In my Dodge the knock went away on start up, I have noticed this with Mobil 1 in other cars I owned and other poples cars. Chrysler always stated to install a filter with a check valve so the oil would not drain back overnight. Orange is Fram, this list we had to choose from was Wix, Napa (they are the same), Mopar, Ac delco, Puralator and two or three more that I can't think of. Around here the orange filter was not sold for years, just making a comeback in the late 90's early 2000. I use the Mobil filter when I use Mobil1 and Puralator with valvoline. Never had a problem with Mobil1 except start up knock, and no problems with valvoline. I have not performed an oil change on the Suburban but have 5 qts of Mobil1 on the shelf, but not sure if I will use it or switch.

  5. #15

    Default

    Yeah, Fram is unchartered waters for me as I have never used one due to their reputation as being junk.

  6. #16

    Default

    My Suburban Has 180,XXX miles on it Mine does the same on start-up when its cold its alot worse.I think its lifters seems to clanking/tiny to be mains and it goes away after 20-30 seconds...I always thought if it was main bearings it would have a low clunk clunk at idle and deosnt go away like mine does now...I have an AC delco oil filter and 10-30w oil in it...
    1998 Chevy Suburban K1500

  7. #17

    Default

    yes it is more prominent when its colder .. i like in ohio and its 15 degrees here now .. my truck also has the factory oil cooler that goes to the radiator idk if that would make any difference ..

  8. #18

    Default

    I have the same problem in my 2003 Silverado with 163,000Mi. Piston Slap maybe?
    Current Daily Driver:
    2003 Chevrolet Silverado 1500 - 4WD - 4.8L V8 - True Dual Exhaust Setup, Cat Delete, Cherry Bomb Glass Packs

  9. #19
    Jr. Apprentice
    Join Date
    Nov 2008
    Location
    loudoun county va
    Posts
    20

    Default

    thanks to everyone for the great info in this thread. I performed a seafoam clean out of my block in the summer and the knock is in the head/lifters. does this sound like everyone else's noise?

  10. #20

    Default

    Yes, it's in the valve train, not the bottom end.

Similar Threads

  1. Wining noise a few minutes after startup
    By msvx95 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 9
    Last: 01-14-2013, 07:58 AM
  2. Knocks and Falters
    By wherewasi in forum GM Powertrain
    Replies: 6
    Last: 08-20-2010, 11:53 AM
  3. Truck has low idle/knocks off
    By kgibson181 in forum GM Powertrain
    Replies: 7
    Last: 06-29-2010, 12:58 PM
  4. noise after startup?
    By 2wheelmudder in forum GM Powertrain
    Replies: 8
    Last: 06-06-2010, 04:00 PM
  5. engine rattling at startup
    By tic in forum GM Powertrain
    Replies: 20
    Last: 03-02-2009, 10:25 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •