GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 Last Post byLast Post by
Results 1 to 10 of 13
  1. #1

    Default Fuel gauge needle

    On my 99 Suburban, the fuel gauge needle appears to be vibrating and shakes rapidly back and forth about a needle's width or so. Some say it is most likely the sending unit. Comments?

  2. #2

    Default

    Mine does it too. These gauge clusters fail after a while. Cheap DIY (but PITA) fix.

  3. #3
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,389

    Default

    Its the gauge cluster i replaced mine a few years ago (at a $300 cost) and mine is doing it again. So what its the cheap DIY fix please?
    99 K1500 Suburban LT "THE BEAST"
    Hypertech III, K&N, true dual
    285/75/16
    ___________________________
    Jason

  4. #4

    Default

    Mine was doing the same thing replaced fuel pump and sending unit. Stopped it from jumping up and down.

  5. #5

    Default

    Mine has done it since I got the truck last fall. I would have to guess there is a resistor on the sending unit that must fail.
    I like you.

  6. #6

    Default

    Mine too. The voltmeter bounces with the turn signals, too. If I remember right, it's the servo motors on the back of the cluster that go bad - I think there is a post on the site about where/how to replace them, but I won't have time to look until sometime tomorrow.

    Good luck to us all...

    1999 Chevy K2500 Suburban 350
    K&N, reworked cai, Thrush cat-backs
    Vinyl, cranks, floor shift, and rear air!

  7. #7

    Default

    The stepper motors on the back of the clusters go bad. My gas gauge stopped working completely last year, so I sent my cluster to some guy in Minnesota (through ebay) and for $60, he replaced all of the stepper motors, all of the cluster bulbs and updated the cluster with the newest software. Plus it came with a lifetime warranty, pretty good deal IMO.
    04 ECSB Custom silver & grey, Soft 8's, BFG KO's, ReadyLift Leveling Kit, Hellwig front sway bar, K&N filter, DeeZee EZ-Down, Rhino liner, Alpine CDE103BT, Rockford 6.5's, 12" V.A.T. Hammer Pro in a Subthump box, Alpine PowerPack amp, Hifonics amp, BackRack w/ 55w 5000k HID KC Daylighters, KC light bar with 4 KC Slimlites, UWS toolbox, Shaved Antenna mod, Black Bowtie, LED backup, license plate, dome lights & 3rd brake light


  8. #8
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    With the 95-99 suburbans usually it is the sending unit that goes out as the ground gets corroded in the tank. The stepper motors do fail in those years but usually it is the sending unit. to be honest if it doesnt bother you let it go till it isnt reading correctly since it requires that you drop the tank.
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  9. #9
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,389

    Default

    In mine and other friends it has never been the sensing unit its always been the cluster/stepper motors that fail. @TELORVEHC I suppose you still dont have an address or contact info for the guy in MN that you had replace the motors?

  10. #10

    Default

    Quote Originally Posted by vncj96 View Post
    In mine and other friends it has never been the sensing unit its always been the cluster/stepper motors that fail. @TELORVEHC I suppose you still dont have an address or contact info for the guy in MN that you had replace the motors?
    This is the ebay seller that repaired my cluster---->http://stores.ebay.com/digitalspeedometerrepairservice and the address is 123 W. Sarnia Street, Winona, MN 55987.

Page 1 of 2 12 Last Post byLast Post by

Similar Threads

  1. Fuel gauge needle vibration and radio loosing memory??
    By HighSierra in forum GM Electrical Tech
    Replies: 0
    Last: 09-06-2011, 11:36 AM
  2. fuel/air gauge
    By reggiecab2000 in forum GM Electrical Tech
    Replies: 4
    Last: 08-29-2011, 11:45 PM
  3. Gas Gauge Needle "Vibrates"
    By tattooed4life in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 5
    Last: 08-16-2009, 12:10 AM
  4. Twitching/vibrating fuel gauge - Not the fuel pump assembly.
    By Springthing in forum Audio, Video & Gadget Tech
    Replies: 3
    Last: 09-26-2008, 05:10 PM
  5. Fuel Gauge sender/fuel pump Together-seperate???
    By TahoeCrowe in forum General Chevy & GM Tech Questions
    Replies: 9
    Last: 09-05-2008, 02:55 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •