GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Default !989 chevy truck hard to start cold and tbi overloading?

    I got a 1989 1500 with 350 when it is cold it is hard to start. I have ran my battery before then when i get it cranked and it floods alot and when it gets going it sounds good but it will start to idle high and cuts off sometimes it cranks right back up and sometimes the tbi overloads and want run at all my friend will advance the timing to get it to run then it runs good for a day or so now its flooding out again I am about aggravated with it I changed fuel pump, I rebuilt the fuel regulator and replaced the module under the distributor cap. Any help would be appreciated I am about to get reedy to sell it for a dodge lol.

  2. #2

    Default

    Sounds like IAC (Idle Air Control) valve on the throttle body , Or the fuel pressure regulator in the front part of the throttle body (rebuild-able and easy to do)
    Good Luck

  3. #3

    Default

    Good call Gn..
    2010 Chevy Silverado Z71 ext cab.4x4
    72 Monte Carlo 350-415 hp- sold (June 2011) to pay medical bills
    79 Impala 350 4bbl 375 hp- sold (June 2011)to pay medical bills
    oldfart2413@gmail.com

    "If He asks you to go a mile go two"

Similar Threads

  1. 98 Chevy 1500 5.0 Wont Start Cold
    By derek98z28 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 4
    Last Post: 11-30-2011, 11:46 AM
  2. hard start or wont start 305.
    By timhall1787 in forum General Chevy & GM Tech Questions
    Replies: 4
    Last Post: 09-29-2011, 09:00 AM
  3. hard to start/4.3 v6 chevy truck 2006
    By Gbav1 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 2
    Last Post: 02-21-2011, 12:11 PM
  4. Rough/Hard Idle at Cold Start, fine after ~1min
    By MightyMax in forum General Chevy & GM Tech Questions
    Replies: 3
    Last Post: 10-13-2010, 12:21 PM
  5. Hard/No start when Cold outside
    By THEEDGE714 in forum GM Powertrain
    Replies: 4
    Last Post: 10-29-2008, 03:51 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •