GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1

    Default electrical issues?

    Sorry if I posted this in wrong spot. I have an 08' silverado. My service tire monitor system light has been coming off and on while driving. Then the last couple of days it comes on with the service airbag light and then all my gauges drop to zero. The gauges go back to normal after a couple of seconds. The airbag light goes off a little bit later and then the tire monitor light. There is no change in driving performance when this happens. I'm not sure if it is related but my stereo also quit working before all this started. I would appreciate any help.

  2. #2
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,386

    Default

    you have a warranty? if so use it! even my dads 07 has had some issues and even though it was past warranty the dealership still did it as warranty work s they want to keep him as a customer. Just go back to the dealership, its worth trying to finagle something even if you dont have warranty left.
    99 K1500 Suburban LT "THE BEAST"
    Hypertech III, K&N, true dual
    285/75/16
    ___________________________
    Jason

  3. #3

    Default

    If your like me my 08 is out of warranty also. Is this the stock or aftermarket head unit? I have seen this behavior in my truck when I had the alarm installed....they had something grounded or tapped into something incorrectly. Have you installed anything lately?

    You could try removing the head unit and see if the issues go away.


    GMTruckClub members receive discounts off our normal rates! PM me for quotes! Check out our Films gallery - updated with over 200 Hydro Dip films!

    If it can be painted - it can be Hydro Dipped!

    Get the Gorilla!

    gorilladip.com

    sales@gorilladip.com

  4. #4

    Default

    It could also be a bad TPMS sensor. The do go bad...

  5. #5

    Default

    Quote Originally Posted by surrealone View Post
    It could also be a bad TPMS sensor. The do go bad...
    True but when they go bad you only get the "service tire monitor system" light. He has a bad ground somewhere with all the crazy gauge activity.

Similar Threads

  1. Electrical Issues
    By horsemanmike in forum GM Electrical Tech
    Replies: 3
    Last: 07-22-2011, 09:44 AM
  2. Electrical Issues
    By Joethepoolguy in forum GM Electrical Tech
    Replies: 7
    Last: 03-21-2010, 09:28 PM
  3. Electrical issues
    By okysmokey911 in forum Chevy C/K Truck Forum
    Replies: 4
    Last: 02-05-2010, 09:51 AM
  4. Electrical Issues
    By ChevyFan in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 10
    Last: 12-03-2008, 08:52 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •