GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Default 95 standard shift 2.2 falls flat when accelerate

    new problem no codes idles great and if you press gas slow its fine. if you press flat it will stall unless u let off gas fast. still goes back to good idle.try to move truck you have to really slip clutch and it stil falls flat or stalls???
    forgot replaced fuel pump and fuel presure regulator
    Last edited by earnman; 01-08-2012 at 04:37 PM. Reason: forgot smoe info

  2. #2

    Default

    found problem!! i was brought after the fact. the fuel pump was changed so i checked pressure and found 25 psi. it needs 47 psi . so i pulled pump and found upper hosxe clamp not there makeing fuel leak by . i replace clamp and all is great now

  3. #3

    Default

    Like it when people come back and finish a thread with the cause of the problem

Similar Threads

  1. Replies: 0
    Last: 11-18-2010, 01:00 PM
  2. Clunking when I Accelerate
    By RyDogZ71 in forum General Chevy & GM Tech Questions
    Replies: 2
    Last: 10-18-2010, 08:55 PM
  3. Bad Throttle Response..Doesnt accelerate like i want it to
    By Silverado1500 in forum General Chevy & GM Tech Questions
    Replies: 15
    Last: 10-09-2010, 12:55 AM
  4. clunk when i accelerate
    By rick88122 in forum General Chevy & GM Tech Questions
    Replies: 7
    Last: 12-18-2009, 01:31 PM
  5. Great Falls man faces six felony charges - Great Falls Tribune
    By ChevyFan in forum Chevy Blazer Forum (GMC Jimmy)
    Replies: 0
    Last: 12-25-2007, 01:11 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •