GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 7 of 7
  1. #1
    Sr. Apprentice DanPruski's Avatar
    Join Date
    Jan 2012
    Location
    Wasilla, Alaska
    Posts
    42

    Default 93 K1500 Temp. Guage Reading Cold

    1993 K1500 4.3L V6,

    i changed out the thermostat a number of times, flushed the coolant, and changed the temperature sending unit recently to try to get the guage to read normal around 190, but for some reason it is always reading cold around 140 and doesnt put out the hottest air. Im lost on what to check next. 5 thermostats ive tried and they all have been doing this, and its a brand new sending unit, with new 50/50 coolant since im in alaska.

    Any help?

  2. #2

    Default

    This new a truck has a clutched fan on it. Is there a chance the fan clutch has siezed up on you and is moving too much air even when the vehicle should be in "warm-up" mode. Does the temp guage correspond to one stuck in the radiator top? Just wondering if it is somehow out of calibration. Are your other gauges seemingly reading correctly? Some rigs (not sure about later GM) used a step-down transformer to run gauges on say 4 volts instead of 12v. It would affect all gauges equally if that were the case. In Alaska do folks put those zippered covers on the front of the grille during winter. I always ran a piece of cardboard between my radiator and the grille on my little 4-cylinder car to get more/quicker heat in the winter time, but it ran an electric fan. Otherwise my carb with after-market air filter would "ice-up" even in Northern CA.
    I hope it is something simple. I've heard of people who swear by various brands of T-stats and condem others as junk!
    Good luck, Chris
    1996 Chevy Express van, raised top, wheelchair lift, etc. 350 Vortec V-8, auto., tow hitch
    1986 Chevy G20 3/4-ton Beauville window van, wheelchair lift, 6.2L diesel n/a, 700R4, EGR delete, otherwise stock
    1977 Lancia Beta HPE, twin-cam 4, 5-speed, classic Italian hatchback, semi-restored
    various motorcycles

  3. #3
    Sr. Apprentice DanPruski's Avatar
    Join Date
    Jan 2012
    Location
    Wasilla, Alaska
    Posts
    42

    Default

    negative, my 93 doesnt have a clutched fan, it just runs with serp. belt. and the radiator cap doesnt have any tye of guage on it, its just a pressure cap. Other guages seem normal.
    and yeah i throw a piece of cardboard between the radiator and core support to block most of the cold air from coming into it.

    yeah ive tried the Fail-Safe tstats and they didnt change anything so went back to the OEM replacement Murray ones.

  4. #4

    Default

    Quote Originally Posted by DanPruski View Post
    negative, my 93 doesnt have a clutched fan, it just runs with serp. belt. and the radiator cap doesnt have any tye of guage on it, its just a pressure cap. Other guages seem normal.
    and yeah i throw a piece of cardboard between the radiator and core support to block most of the cold air from coming into it.

    yeah ive tried the Fail-Safe tstats and they didnt change anything so went back to the OEM replacement Murray ones.
    I looked up the 4.3L V-6 in a K1500 and the stock fan clutch is AC Delco Part #154552. My 1996 van with serpentine belt has a clutched fan, it is just another type of thermostat that lets the fan blades more-or-less freewheel until it reaches higher temperatures. You should be able to tell whether it is functioning by just trying to turn the fan blades on a cold engine by hand. The viscous nature of the clutch should let it turn without moving the belt.
    Never heard of Murray T-stats; always figured stock GM was AC Delco. The idea with the rad cap is to remove it and run the engine up to "normal" operating temperature with a kitchen thermometer immersed in the coolant. That way you can compare what is circulating through the radiator with what the gauge is telling you.
    1996 Chevy Express van, raised top, wheelchair lift, etc. 350 Vortec V-8, auto., tow hitch
    1986 Chevy G20 3/4-ton Beauville window van, wheelchair lift, 6.2L diesel n/a, 700R4, EGR delete, otherwise stock
    1977 Lancia Beta HPE, twin-cam 4, 5-speed, classic Italian hatchback, semi-restored
    various motorcycles

  5. #5
    Sr. Apprentice DanPruski's Avatar
    Join Date
    Jan 2012
    Location
    Wasilla, Alaska
    Posts
    42

    Default

    ohh weird, ive never heard of it or noticed it having a clutched fan. so just reach down and turn it by hand without moving the belt? so basically your saying the fan might be turning with the belt all the time and it shouldnt?
    The Murray ones is just what O'rielly sells as their standard coolant stuff. Anyone i talk to never has problems with that brand, they sell OEM replacement and Racing equiptment for cooling systems.
    and okay, ill try that tonight with checking the coolant temp in the radiator.

  6. #6

    Default

    Yup, that's right on turning the fan blades without the pulley moving against the serpentine belt. Another good check is to see whether the center of the radiator stays cooler than the top/bottom/sides (depends on where the "tanks" are located. If the center stays cooler it is a sign your core is plugged; with a plugged core your coolant could be "short circuiting" and never really circulating through the entire engine to pick up that heat you are looking for. Basically you want a uniform temperature more/less across the core. An infrared gun-type thermometer is good for checking this, but it can be done by touch. I assume you have the process of bleeding air from the system down to a science, having done 5 different T-stat changes.
    BTW- how many miles are on this rig and when was the last water pump installed. I've heard horror stories of the impeller vanes getting eaten away by corrosive water/antifreeze and the darn thing just spins around without pushing the coolant where it needs to go. Typically the opposite of what you are describing results - overheating.
    Chris
    1996 Chevy Express van, raised top, wheelchair lift, etc. 350 Vortec V-8, auto., tow hitch
    1986 Chevy G20 3/4-ton Beauville window van, wheelchair lift, 6.2L diesel n/a, 700R4, EGR delete, otherwise stock
    1977 Lancia Beta HPE, twin-cam 4, 5-speed, classic Italian hatchback, semi-restored
    various motorcycles

  7. #7
    Sr. Apprentice DanPruski's Avatar
    Join Date
    Jan 2012
    Location
    Wasilla, Alaska
    Posts
    42

    Default

    okay, yeah ill check that out. And do you mean the heater core? im gonna try flushing it tonight as well, just pull the hoses and put the garden hose in it.
    The truck has 281K, enging had about 80K, i havent changed the water pump on this engine yet i dont think. Yeah bleeding air is definately down to a science.

    05 Silverado 1500 LS 5.3L.
    6" fabtech lift, 35x12.5 Nitto Mud Grapplers, 20x10 XD Monster wheels. MagnaFlow dual exhaust, AEM cold air intake, custom tune.
    35W 5K HID low,fog, 55W highs, Hi-6 Mod, black tail lights.
    Color matched front and rear bumper caps, fully debadged.
    5% tint all around, 35% full windshield with 10" 5% brow.
    7" pioneer touchscreen Double Din, 2 Rockford R1-12's under the seat with Rockford P300-1amp, Rockford prime speakers all around, LED interior Lights.

Similar Threads

  1. temp. guage fluxuating
    By tcook18 in forum GM Powertrain
    Replies: 2
    Last Post: 01-13-2010, 12:46 PM
  2. Temp gauge not reading right 2003 silverado
    By crazylikeacharger in forum General Chevy & GM Tech Questions
    Replies: 1
    Last Post: 12-28-2009, 03:43 PM
  3. Temp Guage Not Working
    By BIGFOOT in forum General Chevy & GM Tech Questions
    Replies: 0
    Last Post: 12-31-2008, 12:49 PM
  4. SES light, no temp reading
    By hockeyham in forum Chevy Trailblazer Forum (GMC Envoy)
    Replies: 0
    Last Post: 10-30-2008, 12:29 AM
  5. temp guage.
    By thebandit110 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 0
    Last Post: 12-19-2007, 04:01 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •