GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 Last Post byLast Post by
Results 1 to 10 of 15
  1. #1

    Default 97 GMC Suburban Died...What Happened?

    97 GMC Suburban Died...What Happened?


    Well, I was driving along the highway last night at about 60 and as I went down a small hill, I felt a sudden shrug of the vehicle, but for a few seconds, I thought the cruise control had simply stopped because I was going a little faster down the hill, but in a few seconds more, I realized the truck was slowing down still!

    I was able to top the hill and exit the freeway where I went down the ramp and into a Taco Bell parking lot,..at 2:00am in a very bad area. Scary...nope, left the cell phone back home.

    The Taco Bell employees were inside, but when I tapped on the locked door and asked them to make a call for me, they acted like I was one dumb sob freezing in the night as they openly laughed at me. This went on for half an hour, but I had no other choice but to be persistent. They eventually came out to their cars to go home at which point the laughing had ceased when I confronted them again asking the three to make a call which one finally did.

    The truck sat there in the middle of the parking lot. All systems seemed to be working perfectly except for the fact that the engine just turned over and would not start.

    It appeared that no gas was getting to the engine. I'm guessing its a dead fuel pump, but it seemed really odd that the truck was running fine then it just died at 60mph.

    I bet one of you has had this happen, as well. Its freezing cold outside. A bit of your knowledge would sure help about now.

    Thanks much,

    Tracey

  2. #2

    Default

    Tracey: lets start with a description of which engine you have in your truck and if you know of any maintenance or repairs done.
    This issue could be Fuel or electrical, or a combination of both. It's gonna require a little troubleshooting and some of this troubleshooting will be engine specific.

  3. #3

    Default

    Certainly, the Suburban is a 1997 V8 - 5.7L vin R 350ci - MFI GAS OHV with 127,000 miles on it.

    Exceptional care has been given to the engine and transmission.

  4. #4

    Default

    You say freezing... Frozen fuel line? Any gas line antifreeze in it?
    Any fuel pressure? Or when you turn the key to on do you hear the fuel pump?
    Do you have spark?
    Last edited by jake's silverado; 01-21-2012 at 10:47 AM.
    Finally a signature and Avatar! I also posted some pics in the Gallery.
    2011 2500HD Crew Cab 4X4 Z71 6Liter.
    2011 Outback Travel Trailer 260FL
    So Happy to not be on the edge of GVWR Over Load!!

  5. #5

    Default

    Sudden death normally points at an electrical issue, with fuel problems they'll stumble a little before dieing, but you were going down hill with cruise on so it could have stumbled before you were aware of the problem.
    Check all the fuses underhood and under the dash.
    Make sure you definately have fuel in the tank (not trying to insult anyone here but empty fuel tanks have been the source of more than one mysterious dead vehicle with an intelligent mechanic trying to figure out the problem).
    Next step will be to ensure the fuel pump and injectors are working.
    And that you have spark to the engine.

  6. #6

    Default Update

    I've checked the following:

    Fuel pump can be heard when key is turned.
    FP fuse and relay are in good shape.
    Gas in the tank
    Engine barely and I mean barely fires up when key is turned.

    Fuel filter has not been changed in recent months.

    What are the chances that its a bad fuel filter .... this happened five minutes after I put fuel in the tank?

    Does anyone know where the fuel filter is? I let my garage take care of that.

  7. #7

    Default

    Quote Originally Posted by Tracey121 View Post
    I've checked the following:

    Fuel pump can be heard when key is turned.
    FP fuse and relay are in good shape.
    Gas in the tank
    Engine barely and I mean barely fires up when key is turned.

    Fuel filter has not been changed in recent months.

    What are the chances that its a bad fuel filter .... this happened five minutes after I put fuel in the tank?

    Does anyone know where the fuel filter is? I let my garage take care of that.

    Tracy, the Fuel Filter is located on the Driver-side, on the inside of the fame rail......along with replacing the fuel filter, I would also have the fuel pressure checked.....at this point it can't hurt and/or cost anything to have the fuel pressure checked.

    MIKE


    99"SILVERADO
    5.3 l 3.73 l G80
    BLACK BEAR CUSTOM TUNE
    SNUGTOP l COLORMATCH l KATZKIN










  8. #8

    Default

    Quote Originally Posted by Tracey121 View Post

    What are the chances that its a bad fuel filter .... this happened five minutes after I put fuel in the tank.
    So it sounds like the it still runs but runs like crap. Water in the gas will do this. I have had bad gas (ha ha) and it doesn't take much water. Rule this out with gas line anti freeze. That's what I would do first.

  9. #9

    Default

    Quote Originally Posted by Tracey121 View Post
    Engine barely and I mean barely fires up when key is turned.
    What are the chances that its a bad fuel filter .... this happened five minutes after I put fuel in the tank?
    Is the engine firing now?
    Or do you mean turns over?
    Water or bad fuel could create this type problem, the solution for that would be to put an additive in the tank as posted or drain the tank, I'd try an additive first cheap and lots easier.

  10. #10

    Default

    Fwiw, our '97 did the exact same thing during our road trip last July on a cold Wisconsin night. Had it towed to our son's house, and after sunrise I dug into it to source the problem. Loose connection on the larger alty wire.

    Just something to consider in the future.....
    I support gay marriage. As long as both chicks are hot..........

Page 1 of 2 12 Last Post byLast Post by

Similar Threads

  1. Battery not charging and '03 Suburban died
    By Snoburbun in forum GM Electrical Tech
    Replies: 13
    Last: 09-09-2011, 11:17 PM
  2. 2001 Suburban died and won't start.
    By davinnyjk09 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last: 07-02-2011, 04:21 PM
  3. 1999 7.4l suburban died while driving and will not start
    By Breadfather in forum GM Powertrain
    Replies: 11
    Last: 02-17-2011, 05:37 AM
  4. 91 Suburban died on interstate
    By BustedKnuckles in forum Performance & Fuel
    Replies: 9
    Last: 09-12-2010, 06:51 PM
  5. 2001 Suburban Died, Won't Start
    By sgt_in_usaf in forum GM Powertrain
    Replies: 13
    Last: 02-14-2010, 05:15 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •