GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4
  1. #1

    Default 99 Suburban heating problems!!!!

    Hello All,

    I am brand new to this forum...it's great to see a bunch of Chevy guys and gals helping each other out!!

    Now for my question....I have a 99 1/2 ton Suburban with a 5.7 that I'm having some issues with. I bought it this fall with 130k on it. When I bought it, the intake was leaking (as they all do at one point). The seller claimed to have not noticed this and it appeared to be a small leak off the back of the manifold. I bought it at a reduced price with the knowlege I'd have to fix it. I went ahead and fixed it...replacing all the gaskets in the kit and all ignition parts (cap, rotor, plugs, wires). The only thing I didn't replace was the thermostat.

    Jump ahead to winter months....I noticed the heat wasn't blowing very warm....obviously should have done the thermostat when I had it apart. After replacing, I noticed the front was blowing pretty warm, but the rear was blowing cold. After driving it and checking some more....I noticed that while driving at highway speeds or higher than idle RPM's (about 2500 or so), the front and rear heat were blowing warm, acceptable air temps. As soon as I slowed to an idle, the front temp dropped slightly, but the rear went to cold.

    I talked to some different people and came up with two possible problems....a bad thermostat, or an air pocket somewhere in the system. So....I put in another thermostat and let it idle with the front and rear jacked up high trying to get the air out. None of this worked....I still have the same problem.

    I'm beginning to think the previous owners knew about the leak and filled the radiator with stop leak. Before I go buy a few more gallons of the pink antifreeze and radiator flush.....anyone have a better idea or a similar problem??? Any help would be great.....it's been around 0 degrees here (Montana) for the last week!!!

    JZ

  2. #2
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,378

    Default

    have a shop do it, my suburban has been tricky when I replaced the thermostat for some reason, i always got hot air but the engine temp would fluctuate too much and I did everything imaginable to try and get the air out, these systems are bigger then normal so I just paid someone to replace the thermo and no porblems at all since then. Did you power flush the system when you did the gaskets?
    99 K1500 Suburban LT "THE BEAST"
    Hypertech III, K&N, true dual
    285/75/16
    ___________________________
    Jason

  3. #3

    Default

    NO....I didn't flush it.....and I pulled the block plug from the side to drain the block and keep as much coolant out of the engin as possible. I noticed my temp guage fluctuating with this newest thermostat also. It runs up to about 205, then quickly drops. But it only does that once then seems to maintain. Thanks for the tip!

    On a different note...the Chip, Intake,and exhaust make a noticeable difference on yours??

    JZ

  4. #4
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,378

    Default

    The only reason i got the hypertech programmer was so that i could change the tire size as i used to have 285s on it, plus i can now read codes with it too. it does have the higher octane tuning (i dont use it, gas is expensive enough without using high octane) and it does allow to recalibrate for the hypertech thermostat (which i never used either), the intake and exhaust really did help with the upper RPMs, so passing a car at highway speeds it can climb a little quicker and doesnt seem to struggle as much as it did before i had them. My intake is a k&n filter on a cheap ebay tube. I origianlly had a magnaflow duel in/out muffler on it but was not happy with it. It had HORRIBLE drone and it rotted off in under 2 years, so now i have a flo pro muffler and am very happy with it, no drone but you can still hear the exhaust on the highway but has a very nice growl when you get into it.

Similar Threads

  1. New memeber with a question about my 99 Suburban heating
    By JZ_745 in forum Member Introductions
    Replies: 5
    Last: 01-24-2012, 05:41 PM
  2. Silverado Cab Heating
    By AKRide907 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 12
    Last: 12-01-2011, 05:56 PM
  3. Over heating!help!
    By Edgar_505 in forum GM Powertrain
    Replies: 4
    Last: 07-26-2011, 05:35 PM
  4. Heating issues
    By joker_fly in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 4
    Last: 12-28-2009, 11:53 AM
  5. Heating and AC
    By ebollard in forum General Chevy & GM Tech Questions
    Replies: 0
    Last: 06-01-2008, 07:24 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •