GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2
  1. #1

    Default Speedometer works when cold and quits when truck warms up

    I have a '89 K2500 Silverado, 5.7L, AT, when its cold (30 degrees-ish) the speedometer works, but when the truck warms up a few minutes it quits. What's the deal? How do I fix?

  2. #2
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    Sounds like the speed sensor is going bad, or else the harness..
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

Similar Threads

  1. car wont start when it warms up!!
    By chancek31 in forum Chevy Camaro Forum
    Replies: 3
    Last: 10-26-2011, 12:31 PM
  2. Chevy 7.4 Starts and then Quits
    By lute in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 4
    Last: 10-24-2011, 05:43 AM
  3. Replies: 6
    Last: 05-25-2011, 08:46 PM
  4. 2001 chevy suburban 5.3 quits. 115K
    By japsmash2001 in forum General Chevy & GM Tech Questions
    Replies: 4
    Last: 11-16-2010, 05:58 PM
  5. Replies: 0
    Last: 12-11-2009, 04:11 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •