GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2
  1. #1

    Default 93 s10 no high idle when its cold outside

    93 s10 2.8 5 spd. now that its cold outside my truck does not want to high idle and keeps stalling out. but after i get going it bucks and hesitates for about a block or so than runs fine. any ideas?

  2. #2

    Default

    If you don't have a high idle when you start it, I'd take a look at the IAC pintle and the passages in the TBI. Unscrew the IAC (idle air control) and clean the pintle with carb and choke cleaner. Also, spray some down into the hole while you have it out and see what happens. You also might want to scan the computer and see if the IAT sensor and the Coolant Sensor are reading correctly. They should read the same on a cold engine before startup.
    Good Luck and God Bless

Similar Threads

  1. high idle
    By racerx in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last Post: 12-02-2010, 08:06 PM
  2. high idle/ high engine compartment heat
    By lynx in forum General Chevy & GM Tech Questions
    Replies: 3
    Last Post: 09-05-2010, 03:03 PM
  3. High idle rev w/ A/C on
    By letmusiclive in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last Post: 06-29-2010, 09:49 PM
  4. High Idle
    By Chevyguy in forum The Coffee Shop ~ Chit Chat
    Replies: 2
    Last Post: 09-20-2007, 10:09 PM
  5. idle way high
    By 89suburban350 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 6
    Last Post: 07-16-2007, 11:22 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •