GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Default tow/haul not working

    So I have another issue with my 2000 Silverado Z71 with the 5.3L I went to haul some motorcycles and wanted to use the tow/haul feature on the shift and now it doesnt work it does not light up on the cluster. What should I check? I did check all the fuses and they were fine.

  2. #2

    Default

    What most likely has happened is.....the Wire that runs from the Tow Haul Button, down the Shifter and then down the Steering Column and at the base of the Steering Column..........overtime the Wires will sometimes get Pinched and/or Frayed.......below is a link with a Picture of where the Wire is located and how to repair it......

    Starting on Reply Number #9,
    http://www.gmtruckclub.com/forum/sho...ght=haul broke

    MIKE


    99"SILVERADO
    5.3 l 3.73 l G80
    BLACK BEAR CUSTOM TUNE
    SNUGTOP l COLORMATCH l KATZKIN










  3. #3

    Default

    I looked for damaged wires last night and found nothing...

Similar Threads

  1. Tow Haul
    By 1flyfisher in forum General Chevy & GM Tech Questions
    Replies: 1
    Last: 04-17-2010, 08:04 AM
  2. tow/haul not working
    By bigbrett in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 1
    Last: 02-22-2010, 08:25 PM
  3. tow/haul
    By judsteele in forum General Chevy & GM Tech Questions
    Replies: 0
    Last: 11-16-2009, 08:13 AM
  4. tow/haul not working or bulb out?
    By slim in forum General Chevy & GM Tech Questions
    Replies: 3
    Last: 07-30-2009, 10:02 PM
  5. Tow / Haul
    By bzboardco in forum GM Powertrain
    Replies: 2
    Last: 01-05-2009, 11:41 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •