GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1
    Jr. Apprentice
    Join Date
    Oct 2007
    Location
    Redding, CA
    Posts
    22

    Default Starting issue Please help

    I just got my 93 suburban back from the trans shop. Drove stright home and turned it off. I got out looked under it then went to start it again and just clicking. Pulled the battery and starter and had them tested and they check out great. Could it be something the trans shop did? If it rotate the engine by the crank pulley it will give a quarter of a crank then click. Could the starter check out but not have enough to turn it over? TIA

  2. #2
    Jr. Apprentice
    Join Date
    Oct 2007
    Location
    Redding, CA
    Posts
    22

    Default

    Never mind it was the freaking ground cable needed cleaned!!!

  3. #3

    Default

    I was just going to say that, until I read your own answer. Good for you.



    Jamie

    2007 Ford E250(Work van) (Ya, Ya, shut up!)
    1996 GMC Sierra SLE 1500 5.7L/4L60E

Similar Threads

  1. 1995 Silverado Starting Issue
    By Skro in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 7
    Last Post: 05-02-2010, 12:54 AM
  2. jimmy starting issue
    By ChevyPrincess in forum General Chevy & GM Tech Questions
    Replies: 5
    Last Post: 07-20-2009, 09:03 PM
  3. Help starting issue!
    By FireRed in forum Performance & Fuel
    Replies: 2
    Last Post: 04-06-2009, 10:22 AM
  4. Cold starting issue!
    By FireRed in forum Performance & Fuel
    Replies: 9
    Last Post: 12-25-2008, 11:29 AM
  5. Starting issue
    By ferco in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last Post: 11-13-2008, 08:29 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •