GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4

Thread: Weak Spark?

  1. #1

    Default Weak Spark?

    When i go to start the engine over it just turns over and over but doesnt fire. I drove it with a load of hay, it ran fine but the next day when i went to fire it up, nothing. It has air and gas but a weak spark, ive replaced the distributor cap, rotor, coil, ingnition control modual, pick up coil is good and the plugs. And if i tested it right, contintuity is okay. Im kinda stumped at this point. Check for a spark and get a orange colored spark. I know its supposed to be blue. Any ideas of what could be the problem? Please help me out!

  2. #2
    Sr. Engineer Dana W's Avatar
    Join Date
    Dec 2011
    Location
    Chuluota, Florida
    Posts
    361

    Default

    Quote Originally Posted by Niekamp-Alaska View Post
    When i go to start the engine over it just turns over and over but doesnt fire. I drove it with a load of hay, it ran fine but the next day when i went to fire it up, nothing. It has air and gas but a weak spark, ive replaced the distributor cap, rotor, coil, ingnition control modual, pick up coil is good and the plugs. And if i tested it right, contintuity is okay. Im kinda stumped at this point. Check for a spark and get a orange colored spark. I know its supposed to be blue. Any ideas of what could be the problem? Please help me out!
    You didn't mention the battery.

  3. #3
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    Also we need to know year make and model which engine etc.
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  4. #4

    Default

    I'd suspect low battery voltage while cranking.
    2010 Silverado LT 1500 5.3L 4X4
    '95 BMW K1100LT
    '97 BMW K1100LT

Similar Threads

  1. 2006 4.3L= Weak SAUSE
    By gs500fmode in forum Performance & Fuel
    Replies: 7
    Last: 01-25-2011, 11:50 AM
  2. soft/weak brakes
    By spazzoid13 in forum Lifted & Offroad Suspension
    Replies: 6
    Last: 12-29-2010, 07:48 AM
  3. weak towing
    By jiujitsu in forum GM Powertrain
    Replies: 6
    Last: 04-10-2010, 08:20 PM
  4. One Channel Is Weak
    By Tom Evans in forum Audio, Video & Gadget Tech
    Replies: 6
    Last: 09-05-2007, 07:20 AM
  5. weak brakes
    By proe305 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 4
    Last: 04-05-2007, 10:55 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •