GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4
  1. #1
    Jr. Apprentice
    Join Date
    Sep 2011
    Location
    Hermantown, MN
    Posts
    12

    Default Rough Idle, Check Engine Light

    I have a 2005 Silverado 1500 with the 5.3L engine with 62,000 miles. I had just left home yesterday and came to a stop at a stop light when I noticed the engine was idling rough. It was enough to make the tach fluctuate a little and I could feel it in the cab. As soon as I accelerated the roughness went away and everything seemed to be fine. When I came up to the next light the rough idle came back. At the third stop light in addition to the rough idle I could smell a strong sulfur catalytic converter smell and the check engine light started flashing. Once I was moving again the smell and roughness went away, but the light stayed on. Anyone had a similar experience? Any suggestions?

  2. #2
    Legend

    Red Z71 Max's Avatar
    Join Date
    May 2011
    Location
    Myrtle Beach, SC
    Posts
    2,334
    Blog Entries
    1

    Default

    Sounds like an O2 sensor or possibly the Catalytic Converter is starting to plug.

    (Scott) Myrtle Beach, SC
    January 2012 ROTM WINNER
    2011 GMC Sierra Z71 MAX 6.2 L w/ Trailering Package
    Rough Country, XD Rockstars, Nitto Trail Grapplers, N Fab, Lund Genesis, Putco, Gator Grip,
    Flowmaster 40 series, Diablosport InTune, Banks Ram Air CAI,
    WeatherTech, AVS Aeroskin, Tow Mirrors, Upgradeyourauto.com

  3. #3

    Default

    Quote Originally Posted by npete7381 View Post
    I have a 2005 Silverado 1500 with the 5.3L engine with 62,000 miles. I had just left home yesterday and came to a stop at a stop light when I noticed the engine was idling rough. It was enough to make the tach fluctuate a little and I could feel it in the cab. As soon as I accelerated the roughness went away and everything seemed to be fine. When I came up to the next light the rough idle came back. At the third stop light in addition to the rough idle I could smell a strong sulfur catalytic converter smell and the check engine light started flashing. Once I was moving again the smell and roughness went away, but the light stayed on. Anyone had a similar experience? Any suggestions?
    If you go to your Local Auto parts Outlet, Auto Zone, O'Reillys etc, they will at no charge, Scan your Trucks Computer, and will be able to pull the Trouble Code that is causing the Check Engine Light to come on, at that point you'll be able to know for sure what the Problem and/or Issue is.....From what you have expresses, the Problem as mentioned above......may be with the Catalytic Converter.
    Last edited by 99'HEARTBEAT; 02-11-2012 at 04:24 PM. Reason: Added Infor.

    MIKE


    99"SILVERADO
    5.3 l 3.73 l G80
    BLACK BEAR CUSTOM TUNE
    SNUGTOP l COLORMATCH l KATZKIN










  4. #4
    Jr. Apprentice
    Join Date
    Sep 2011
    Location
    Hermantown, MN
    Posts
    12

    Default

    Looks like it's an O2 sensor, which is what I was thinking/hoping (vs. a problem with the cat) Stopped by my local Advanced Auto today and used their scanner and got the following codes:
    P0131 - Left bank upstream sensor, low circuit voltage
    P0171 - Left bank upstream sensor, lean mixture
    P0300 - Random engine misfire

    Of course I had to order the sensor, so it'll be a day or two before I get it fixed but at least it's not something more serious. Thanks for your replies!

Similar Threads

  1. Help! New Guy with Check Engine Light
    By Boonduff in forum GM Powertrain
    Replies: 9
    Last Post: 09-18-2011, 02:31 AM
  2. Service light v.s check engine light
    By redbone in forum Chevy C/K Truck Forum
    Replies: 1
    Last Post: 07-21-2011, 11:04 AM
  3. Check engine light on.
    By Andy7 in forum Performance & Fuel
    Replies: 4
    Last Post: 07-16-2010, 01:26 PM
  4. check engine light
    By Whits96 in forum General Chevy & GM Tech Questions
    Replies: 6
    Last Post: 01-20-2009, 12:50 AM
  5. Need help, engine won't idle, runs rough
    By rickyg1 in forum Performance & Fuel
    Replies: 23
    Last Post: 09-09-2007, 09:44 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •