GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 9 of 9
  1. #1

    Default Suburban 6.5L Turbo Diesel

    Hi !
    Iīve just bought my Chevrolet Suburban -1997 Turbo diesel , and I canīt get the turbo to charge , only when i pull the westgate tube .
    Iīve bought a new " cellunoid " ? and replaced it , still it wonīt charge .. Iīve also checked the vakuum tubes and they seems to be fine.


    Also when I drive the 4L / 4H and the 2L / 2H switches keep blinking and it makes a wierd noise from the front wheels.

    Does anyone have any idea of what the problems can be ??





    Sorry for my bad english.

    / Dennis

  2. #2

    Default

    did you check to see how much vacuum the vac pump makes? It's a common problem for the vac pumps to fail.
    Joseph


    Airforce Veteran (7 years)


    NRA Life Member

  3. #3
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    Quote Originally Posted by Joeairforce View Post
    did you check to see how much vacuum the vac pump makes? It's a common problem for the vac pumps to fail.
    I second that..
    As to the 4wd problem, the noise and flashing lights indicate there is a problem. with the 4wd solendoids, i would disconnect the front axle solenoid to see if the lights quit flashing. if so then there is a short either in the switch, the wiring, or the solenoid in the front. (usually it is the solenoid)
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  4. #4

    Default

    Thanks for the tips , im going to check it out as soon as i get to the garage !.

  5. #5

    Default

    I would delete the vaccum pump and boost solenoid, and install a Heath turbo master wastegate controller.

  6. #6

    Default

    Quote Originally Posted by SuperSport01 View Post
    I would delete the vaccum pump and boost solenoid, and install a Heath turbo master wastegate controller.
    When working properly the factory system is much better.

  7. #7

    Default

    ^That may be true for some but it works fine for me. I like the fact that I'll never have to install another vacuum pump or boost solenoid.

  8. #8

    Default

    I rather not get new parts as I live in sweden and parts for USA cars are hard to get, And if u somehow find what your looking for itīll be doubled the price as it would cost in usa. I got a price from mekonomen ( our local part shop ) on a 5" lift kit , and that wouldīve cost about 3200$ for my suburban if I done the work my self. I donīt know how much it wouldīve cost to import tho, Does anyone have any idea what the price would be in usa ?.

    As regarding the turbo , the vacuum should be enough .
    If i pull off the westgate tube isnīt the turbo supposed to get full charge ?
    Anyone who has more ideas of how I could get it to charge ?
    Maybe the westgate is broken ?
    Also I had a thought about the "rods" inside the turbo might be broken so the gate wonīt open / close ?


    / Happy for answer

    Dennis

  9. #9

    Default

    Got it fixed !
    There were holes in the front exhaust, so i welded it and now it runs fine.
    Thanks for all the answers tho !

Similar Threads

  1. Replies: 0
    Last: 01-22-2012, 07:40 AM
  2. Parting OUt 1996 GMC Suburban 7.5 turbo diesel, 14 bolt rear, etc.
    By JBecker in forum General Classifieds
    Replies: 1
    Last: 01-14-2012, 11:21 AM
  3. 1994 diesel 6.5 turbo suburban silverado project parts
    By ChevyFan in forum Chevy Parts eBay
    Replies: 0
    Last: 11-13-2010, 02:20 PM
  4. 1994 Suburban Turbo Diesel 4x4 FS
    By rrrocketrider in forum General Classifieds
    Replies: 0
    Last: 01-27-2007, 08:59 PM
  5. FS: '83 c2500 Suburban Diesel TURBO!
    By OldDiesel in forum General Classifieds
    Replies: 20
    Last: 11-10-2006, 01:00 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •