GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 7 of 7

Hybrid View

  1. #1
    Jr. Apprentice
    Join Date
    Mar 2010
    Location
    Kankakee, Illinois
    Posts
    27

    Default Trans lines replaced - Now CEL on..UUGGGHHH!!!

    Dropped my truck off this morning at a local repair shop with leaky transmission lines. Shop had it "fixed" by 12:00pm so I stopped by to pay for it ($158) and get my key back. Receipt shows they replaced 3 trans lines. Wife brings me to the shop tonight to pick up the truck and the CEL is now on. So, I shut off and dropped the key back into the key drop. I'll be calling them back in the morning.

    Any idea what they could have done in the process of changing trans lines to cause a CEL??

    Thanks!!

  2. #2
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    without knowing the codes that the cel is on for it really isnt easy... and it could have just been something that was on its way out as well. Year make and model would help in the future too thanks.
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  3. #3
    Jr. Apprentice
    Join Date
    Mar 2010
    Location
    Kankakee, Illinois
    Posts
    27

    Default

    Quote Originally Posted by murdog94 View Post
    without knowing the codes that the cel is on for it really isnt easy... and it could have just been something that was on its way out as well. Year make and model would help in the future too thanks.
    Sorry about that, I was venting a little frustration at the time. Its a 2007 Classic LT with the 4.8L V8. I would of fixed it myself if it wasnt 30 degrees out. I ashould have more information this afternoon. Thanks for the reply!

  4. #4

    Default

    $158 . Mine goes in thursday for the same thing 3 line"s for $374.00 i hope i don"t have the same problem ( 2007 LT ext cab 5.3 L )

  5. #5
    Sr. Engineer Dana W's Avatar
    Join Date
    Dec 2011
    Location
    Chuluota, Florida
    Posts
    361

    Default

    Wild guess here. They left an 02 sensor unplugged. Some of that part of the wiring harness runs all over the trans area. They may have had to move some of it.

  6. #6
    Jr. Apprentice
    Join Date
    Mar 2010
    Location
    Kankakee, Illinois
    Posts
    27

    Default

    Turns out the mechanic "bumped" the MAF sensor. He had it fixed this morning before I even got a chance to call. Got the truck home tonight after dark so I havent had a a chance to inspect his work. Just glad to have it home!

Similar Threads

  1. Replaced Hub Bearing
    By BowTieFan1 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 0
    Last: 04-29-2011, 09:19 PM
  2. Has anybody ever replaced an oil pump on 454
    By tmahan319 in forum General Chevy & GM Tech Questions
    Replies: 1
    Last: 12-02-2010, 05:05 PM
  3. Replies: 2
    Last: 11-11-2010, 08:23 AM
  4. Replaced Radiator, but... HELP! Lol..
    By Al Stefanelli in forum General Chevy & GM Tech Questions
    Replies: 7
    Last: 03-05-2010, 09:18 PM
  5. Trans Cooler Lines
    By MD4x4 Fireman in forum Chevy C/K Truck Forum
    Replies: 16
    Last: 08-21-2007, 05:41 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •