GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1
    Jr. Apprentice skhurst18's Avatar
    Join Date
    Jan 2010
    Location
    South Carolina
    Posts
    10

    Default Instrument Cluster

    The Gear and Odometer display went out in my truck recently. I took it out and disassembled it and put it back together and installed it and it worked for a couple of days and went back out. Anyone have any suggestions? Thanks.

  2. #2
    Master Mechanic
    KyleZ71's Avatar
    Join Date
    Jun 2010
    Location
    York and Wilkes Barre, PA
    Posts
    868

    Default

    This is where I went went my cluster crapped out on me. You can find lots of their products on Ebay.
    http://www.fixmygauges.com/Forms.html
    Objects in mirror are losing

    2003 Chevy Silverado Z71, 5.3L, K&N 57 series, 2.5'' Flowmaster Super 10 series dual exhaust , Corvette Servo, McNew Automotive Dyno tune, SS gauge cluster, Extang Trifecta Tonneau, Pacesetter shorty headers, Goodmark cowl hood, Sony Xplod speakers, Kenwood DDX-470 exhaust tips, 16" Ultra Badlands polished wheels, Pirelli Scorpion ATR .

  3. #3

    Default

    Quote Originally Posted by skhurst18 View Post
    The Gear and Odometer display went out in my truck recently. I took it out and disassembled it and put it back together and installed it and it worked for a couple of days and went back out. Anyone have any suggestions? Thanks.
    .....Need a Little more Information, What Year and Model is your Truck??

    MIKE


    99"SILVERADO
    5.3 l 3.73 l G80
    BLACK BEAR CUSTOM TUNE
    SNUGTOP l COLORMATCH l KATZKIN










  4. #4
    Jr. Apprentice skhurst18's Avatar
    Join Date
    Jan 2010
    Location
    South Carolina
    Posts
    10

    Default

    Thanks KyleZ71. I checked out the website. I will have to give them a call.

    ---------- Post added at 06:45 AM ---------- Previous post was at 06:44 AM ----------

    The truck is a 1999 GMC Sierra Z71 Extended Cab.

  5. #5
    Jr. Apprentice skhurst18's Avatar
    Join Date
    Jan 2010
    Location
    South Carolina
    Posts
    10

    Default

    I took the cluster apart and cleaned the contacts that I could get to and the display was working when I installed the cluster. Thanks again for the link to the website.

Similar Threads

  1. Instrument Cluster
    By rtc830 in forum GM Electrical Tech
    Replies: 6
    Last: 02-18-2014, 04:23 PM
  2. LED lit instrument cluster!
    By reggiecab2000 in forum Chevy Truck Accessories
    Replies: 25
    Last: 11-06-2012, 10:47 AM
  3. New Instrument Cluster??
    By GOTSAND4ME2 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 1
    Last: 08-28-2012, 08:39 PM
  4. instrument cluster
    By operatortom in forum General Chevy & GM Tech Questions
    Replies: 4
    Last: 06-17-2010, 01:13 AM
  5. instrument cluster
    By Peckens in forum General Chevy & GM Tech Questions
    Replies: 9
    Last: 08-15-2009, 09:10 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •