GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1
    Jr. Apprentice rkbonds1's Avatar
    Join Date
    Feb 2012
    Location
    Northeast Alabama
    Posts
    13

    Default rear ac not working

    Ok, I'm not familiar with how the rear ac works on the Suburban so I need a little help here. The front ac on my 94 blows ice cold but the rear blows hot. Where should I start looking to figure this out. I would think if it cold in front it would be cold in back? Is there a second compressor/ complete separate ac system for the rear? Any and all help is much appreciated.

  2. #2

    Default

    Both the front and rear A/C run off the same compressor. The difference is, you have two extra lines going to the rear.
    The rear expansion valve is most likely plugged up. That's about the only thing back there that can really stop the flow of freon, and it wouldn't affect the front A/C. It costs about $30, plus the cost of vacuuming and refilling the system. While you're at it, you may as well replace the front orifice tube and the accumulator. The most difficult part will be getting to the expansion valve. You'll have to remove the whole cover on the passenger side to get at it.
    Last edited by Chris Miller; 03-18-2012 at 03:16 AM.
    ...
    ....

  3. #3
    Jr. Apprentice rkbonds1's Avatar
    Join Date
    Feb 2012
    Location
    Northeast Alabama
    Posts
    13

    Default

    Thanks, Chris
    The good part of what you are telling me is all of the front was replaced last year. The bad is having to replace the rear expansion valve. Would you happen to know where it's located? In the truck behind the rear panel or underneath somewhere?

Similar Threads

  1. rear wiper motor not working - fix
    By NeilE in forum General Chevy & GM Tech Questions
    Replies: 2
    Last: 01-12-2012, 12:15 PM
  2. Rear air and heat not working?
    By csmac2004 in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 5
    Last: 10-17-2010, 11:23 AM
  3. 05 Rear A/C not working
    By ChuckT in forum Audio, Video & Gadget Tech
    Replies: 0
    Last: 09-08-2009, 08:57 AM
  4. Rear tail lights not working
    By floutlaws in forum General Chevy & GM Tech Questions
    Replies: 7
    Last: 08-22-2009, 10:21 AM
  5. Rear air not working
    By tekkitan in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 2
    Last: 01-28-2009, 09:37 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •