GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8
  1. #1

    Default Newbie with a problem

    Hi there. I've got a 2002 Express 1500 conversion van.
    When I shut my engine off, the blower motor is still getting power. Even turning off the main selector switch I still end up with a dead battery the next morning.

    After hours of scouring the internet on a solution, it seem's changing the blower motor resister was said to fix it.

    No dice. put in a new resistor & no difference.

    Does anyone have an idea what the problem might be?

    Thank's for any help you guy's can offer.

  2. #2

    Default

    I'm guessing this issue must be pretty rare.

  3. #3

    Default

    i would pull the hvac unit out and see if possibly something is melted. maybe a short happend and jumped somehting causing constant power. if all fails. you can always un hook power wire and wire in a toggle switch to manually kick the blower on and off. be sure to use an inline fuse.

  4. #4

    Default

    Yeah, as soon as it warms up a bit here, I'll start probing the wiring harness. Tried a few days ago, but the wires & plastic sheathing are so cold they won't bend & I'm worried about breaking something from the cold brittleness.

  5. #5

    Default

    Just a guess here, but maybe an ignition switch?
    "It went together didn't it? Well then there has to be a way to take it apart!" - Me.

    Check out my image gallery HERE.



    "The true measure of a man is how he treats someone who can do him absolutely no good." ~Samuel Johnson (1709-1784)

  6. #6

    Default

    Well diagnosing this problem is gonna be a bit harder now. About a week ago it went away. I have an idea what it is, but won't know for sure until I unwrap the wire loom. Have to fix it permanently because sure as **** it'll come back to bite me at the worst possible time

  7. #7
    Sr. Engineer
    Join Date
    Dec 2011
    Location
    11-22-boogie woogie avenue
    Posts
    308

    Default

    How about the switch??

  8. #8

    Default

    Switch has always worked fine, both ignition & master fan control. There's got to be a bad wire or connection somewhere. I'm thinking it's a wire or 2 that has the plastic sheath abraded. I should know in a few days, finally supposed to be warm enough to work on it outside. Conversion top makes it too high to fit in the garage.

Similar Threads

  1. Newbie from UK
    By lightningrod in forum Member Introductions
    Replies: 5
    Last Post: 08-17-2011, 08:11 PM
  2. Newbie with a problem
    By Iceman7578 in forum General Chevy & GM Tech Questions
    Replies: 6
    Last Post: 08-25-2010, 03:53 PM
  3. 96 Chevy tahoe problem fuel problem? Need help ASAP!
    By Fear58 in forum General Chevy & GM Tech Questions
    Replies: 5
    Last Post: 12-13-2009, 05:38 PM
  4. newbie
    By john120789 in forum Member Introductions
    Replies: 9
    Last Post: 03-17-2009, 06:32 PM
  5. Newbie with strange stalling problem
    By repo-man in forum Performance & Fuel
    Replies: 12
    Last Post: 01-02-2009, 06:31 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •