GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1

    Default new alternator not charging

    last night i stop quick at the car wash, shut the truck off for 10 seconhds tops with the lights on get back in and not but crazy dashboard gauges. thinking the alternator finally took a dump i bought a remy 105amp from advance, hook it up jump the truck and the volt gauge was in the midle of the red then dropped to 9V

    what am i missing here, what could have happened in a split second while driving to make the alternator quit charging

  2. #2

    Default

    Have you made sure that there aren't any loose connections/ frayed wires going to and from the alternator?
    04 ECSB Custom silver & grey, Soft 8's, BFG KO's, ReadyLift Leveling Kit, Hellwig front sway bar, K&N filter, DeeZee EZ-Down, Rhino liner, Alpine CDE103BT, Rockford 6.5's, 12" V.A.T. Hammer Pro in a Subthump box, Alpine PowerPack amp, Hifonics amp, BackRack w/ 55w 5000k HID KC Daylighters, KC light bar with 4 KC Slimlites, UWS toolbox, Shaved Antenna mod, Black Bowtie, LED backup, license plate, dome lights & 3rd brake light


  3. #3

    Default

    X2 on loose connections. Maybe a loose ground.

  4. #4

    Default

    X3 on loose connections.
    I was asked to look at a similar situation on a car, and the alternator mounting bolts were loose. The last one to install the alt didn't tighten everything back up.(it had just been replaced the week prior)
    2010 Silverado LT 1500 5.3L 4X4
    '95 BMW K1100LT
    '97 BMW K1100LT

  5. #5
    Sr. Apprentice cedicol's Avatar
    Join Date
    Feb 2012
    Location
    Belgium
    Posts
    62
    Blog Entries
    1

    Default

    It has to be the ground connection.
    life sucks, but i love it!!!!

  6. #6

    Default

    UPDATE!!!, checked ground connections, nw alt. new battery just for good measure
    turn the ign. key to on and only the air bag light comes on
    i've checked all fuses and whatever grounds i can find so far and can find an explaination for this apparent LOCKOUT

    i checked the wires on the alternator they were good and cant find frayed wries since they are inside the black tubing,
    last night i hooked up jumper cables and got it running with the gauges working and could tell the alternator(new) wasnt working

    so my guess is a wire i cant figure out thats locking out the the ign switch(which i shall not replace)

    if anyone knows of common grounds that im missing feel free to tell me

Similar Threads

  1. Replaced alternator, now i'm getting a battery not charging message WTH?
    By obie in forum General Chevy & GM Tech Questions
    Replies: 2
    Last: 03-30-2010, 08:51 PM
  2. alternator not charging
    By js1265 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 2
    Last: 01-27-2010, 06:22 AM
  3. a/c charging to cold
    By pewterburb in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 4
    Last: 10-12-2009, 10:00 AM
  4. Help!!! Charging system!!!
    By pmf608 in forum Audio, Video & Gadget Tech
    Replies: 2
    Last: 01-07-2009, 06:56 PM
  5. Charging issue
    By k.daddy1 in forum Audio, Video & Gadget Tech
    Replies: 5
    Last: 11-14-2008, 03:27 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •