GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4
  1. #1

    Default 1997 S10 trans prob PLEASE HELP!!!!!!

    Hey guys i just bought a '97 4x4 ext cab s10 automatic trans and i love it. the thing is on the way home from buying it it would only go into fourth gear upon letting off the gas so much it would slowly decelerate and going down hill it would go into fourth also. other than that it shift great, there is not metal or shavings on the dipstick and the fluid is very clear, like new fluid. then about half way home "service engine" light comes on so i have it checked at Advance auto parts and its a tranny code P187 "manufactures code". it gave me no bad part info at all. so i had them erase the code and it went into fourth fine after that even under acceleration it didn't shift into third, but once i turned around it starting doing the same crap of staying in third.

    I am at a loss as to what the heack is going on

  2. #2

    Default

    Sounds like someone just changed the fluid before you bought it to mask the burnt smelling fluid.

    Sorry but if people never change the fluid in their automatic transitions and then all of a sudden do after never doing so believe it or not it can trash a trany.

    Technology is great, when it Works,
    And one Big Pain in the Ass When it Doesn’t.
    Detroit Iron Rules, All the Rest are Just Toys.
    94 GMC Burban, 5.7L (350), 4X4, Auto
    86 GMC Burban, 350, 2 WD, Auto
    79 GMC pickup plow truck, 400, Full time 4X4, Auto
    86 Pontiac Fiero SE, 2.8L, Auto, only mid engine American car
    See a Pattern yet?

    15 year GM assembly line worker.

  3. #3

    Lightbulb

    not sure if these later trannys have "vacuum modulators" but that is a similar issue that I had quite a few years back. Took it to the shop a five minute ride and a 20 minute fix and I was gone and happy.

    Phil
    Happy 2 Wheeler!

  4. #4

    Default

    Not every code reader can read manufacturer specific or transmission codes. The first step in diagnosing this is to find someone with a code reader capable of reading transmission codes.

    Your '97 has a 4L60E transmission, which is all electronic controlled -- no vacuum modulators.
    '98 K1500 Suburban LS 5.7 L 4L60E NV246 ARB
    '92 Ford Explorer XLT 4x4 4.0 L A4LD BW13-54 Trac-loc rear
    "My toys were the greasy cogs and springs and pistons that lay around all over the place, and these, I can promise you, were far more fun to play with than most of the plastic rubbish children are given nowadays." Danny in Roald Dahl's Danny The Champion of the World

Similar Threads

  1. 03 Trailblazer a/c prob
    By markwebb30 in forum Chevy Trailblazer Forum (GMC Envoy)
    Replies: 1
    Last: 06-19-2012, 06:13 PM
  2. 90 Suburban blower prob
    By workman4_82 in forum General Chevy & GM Tech Questions
    Replies: 1
    Last: 02-16-2010, 06:53 AM
  3. need help! electrical prob
    By anorfolk in forum General Chevy & GM Tech Questions
    Replies: 3
    Last: 06-17-2009, 08:10 PM
  4. 350 carb prob. help
    By maw454 in forum Chevy C/K Truck Forum
    Replies: 2
    Last: 03-07-2009, 07:31 PM
  5. Replies: 0
    Last: 06-29-2007, 07:26 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •