GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8
  1. #1
    Jr. Mechanic blackburb's Avatar
    Join Date
    Nov 2008
    Location
    In Da U.P. of MI - - M Go Blue!
    Posts
    114

    Default 94 Burb 350 is really weak

    Only 147k, but pulls like it's a 6cyl. Highway mileage has dropped from near 16 to just over 13. Standard tune-up stuff makes no diff. Doesn't use much oil, so I'm wondering about things like plugged cat or worn cam. Any thoughts? Towing anything substantial it really struggles. If I didn't tow, I'd just live with it. But I pull a pontoon boat, enclosed snowmo trailer and travel trailer. Was thinking of dropping in a reman crate motor, but not finding much good response to anything but GM crate motors. No way this truck is worth dropping over $2k plus installation. I remember seeing ads a few years back from Checker for $899 long blocks. That I could do if there's a decent one out there. Any suggestions for ways to figure out what's really wrong without tearing into the motor? It's my only vehicle and can't really take it off the road for any length of time (would have to borrow a ride from my bro). HELP!

  2. #2
    Legend
    murdog94's Avatar
    Join Date
    Feb 2008
    Location
    Cloquet, Minnesota, United States
    Posts
    8,198
    Blog Entries
    12

    Default

    Is the CEL on?? if so check the codes, and if not take a close look at the disributor, i had the same problem with my last GM, and the motor was new.. Turns out the Distributor was shot... Also think about looking at the Fuel Pressure since a weak PSI can cause low power as well.
    Mike

    Currently

    1997 Chevy S-10 Blazer 4X4 with 330K miles and counting (Hunting rig).

    2009 Saturn Aura XE (wifes car)

    2011 F-150 Crew 4X4

    "Hold it to the floor till you see God.... Then Brake!!!!"

  3. #3
    Jr. Mechanic blackburb's Avatar
    Join Date
    Nov 2008
    Location
    In Da U.P. of MI - - M Go Blue!
    Posts
    114

    Default

    No SES and it comes on when I turn the key on. By distributor, do you mean the whole thing? It has a new cap and rotor. Also has new fuel filter. How do you test fuel pressure? There's no schrader vavle.

    Can O2 sensor cause this without throwing a code?
    Last edited by blackburb; 03-11-2012 at 11:23 AM.

  4. #4

    Default

    You have to take out the fuel filter and put in an adapter with a Schrader valve.
    "It went together didn't it? Well then there has to be a way to take it apart!" - Me.

    Check out my image gallery HERE.



    "The true measure of a man is how he treats someone who can do him absolutely no good." ~Samuel Johnson (1709-1784)

  5. #5
    Sr. Engineer
    Join Date
    Dec 2011
    Location
    11-22-boogie woogie avenue
    Posts
    308

    Default

    02 most times will bring a light..engine will stumble ..then light off.
    Is it putting any gray/blackish smoke out the exhaust ?
    Maybe just a good tune up.
    Theses engine can get 300k your just getting started.

  6. #6
    Jr. Mechanic blackburb's Avatar
    Join Date
    Nov 2008
    Location
    In Da U.P. of MI - - M Go Blue!
    Posts
    114

    Default

    It's had two complete tune-ups in the last 20k, plus the new fuel filter. Buddy of mine who knows a lot mechanically seems to think cam, which was my first thought after the tune-up didn't help. No zinc in the new oils and round go the lobes. Gonna do a compression test later this week. It wouldn't hurt my feelings if it was the cam - then I could put in a torquier one.

    Can't see the exhaust from the driver's seat

  7. #7
    Jr. Mechanic blackburb's Avatar
    Join Date
    Nov 2008
    Location
    In Da U.P. of MI - - M Go Blue!
    Posts
    114

    Default

    Here's the update and it's retarded. Both the truck and me. When I said it had a complete tune-up, that wasn't 100% accurate. All the other vehicles I've owned the last several years have had distributorless ignition. I hadn't bothered to check the timing on the Burb. I figured if it wasn't pinging, it was good. Well, turns out it was about 10-12 degrees retarded. I don't know how the hell it ended up there. Hold down clamp was super tight, and when I put my 1/2" drive on the balancer, there didn't seem to be any play in the timing chain. But for whatever reason, it was really retarded. It's like driving a new truck now! I also did a compression check and all was good with that. I'm so happy I don't have to spring for a new motor, but also disgusted with myself for not checking the timing two years ago! I can imagine how much that cost me in wasted gas... I guess we're never too old to learn valuable lessons.

  8. #8
    Legend


    mfleetwood's Avatar
    Join Date
    Jul 2010
    Location
    Denver, CO
    Posts
    7,213
    Blog Entries
    1

    Default

    Congratulations for finding the problem...it appears that now both you and the Burb are not in that "retarded" category any longer


    Mike (Denver, CO) - 2008 Sierra 1500 Z71 SLE 5.3L 4WD

    SUSPENSION: Rancho 4" Suspension Lift; Rancho RS9000XL Shocks; Rancho Skid Plates; Rancho MyRide Wireless Shock Controller;
    TIRES:
    BFG All Terrain KO 315/70/17
    DRIVE TRAIN: 4.56 Gears; Detroit TrueTrac Differential; True Cool 40k Transmission Cooler
    PERFORMANCE: DiableSport Predator Tuner; Custom Tuned by Diablew; Magnaflow Exhaust; AFE Cold Air Intake
    ELECTRONICS: Kenwood DNX6180 Touchscreen; Subthump box w/10" Kicker; Driver Information Center (DIC); Rear View Camera
    ACCESSORIES: Westin Brush/Grill Gaurd; Westin Nerf Bars; Truxedo Tonneau; 20% Tint; Tow Mirrors w/Heat & Signals

Similar Threads

  1. Weak Alternator?
    By Red Rado in forum General Chevy & GM Tech Questions
    Replies: 4
    Last Post: 03-01-2012, 11:54 PM
  2. weak towing
    By jiujitsu in forum GM Powertrain
    Replies: 6
    Last Post: 04-10-2010, 08:20 PM
  3. 88 burb weak on the hills
    By 1988blueburb in forum GM Powertrain
    Replies: 3
    Last Post: 07-08-2009, 11:21 AM
  4. One Channel Is Weak
    By Tom Evans in forum Audio, Video & Gadget Tech
    Replies: 6
    Last Post: 09-05-2007, 07:20 AM
  5. weak brakes
    By proe305 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 4
    Last Post: 04-05-2007, 10:55 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •