GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2
  1. #1

    Default Wont Start. Possible Fuel Pump??

    i Have a 95 k1500 suburban and it wont start most the time. When i turn key on i can hear pump but was wondering could that still be the problem? ive sprayed starting fluid in carb but that dont make it start either it just backfired. Ive changed plugs wires cap and rotor


    Thanks

  2. #2

    Default

    It sounds like you're on the right track. The only way to know for sure is to check the fuel pressure with a gage. It should have 12-15 psi for the TBI system. By the way, when was the last time you replaced the fuel filter?
    Good Luck and God Bless
    Remember that if you're not part of the solution, then you're part of the problem!

Similar Threads

  1. Cranks, got fuel, got spark but wont start
    By bertram31 in forum Chevy C/K Truck Forum
    Replies: 4
    Last: 06-26-2011, 08:08 PM
  2. Help with No Start Issue (Suspect Fuel Pump, Again)
    By alchemist1 in forum GM Powertrain
    Replies: 2
    Last: 06-05-2011, 03:18 PM
  3. HELP!!!!Changed fuel pump and ECM. fuel pump still wont turn on
    By fast_stang_88 in forum GM Powertrain
    Replies: 4
    Last: 06-03-2011, 04:46 AM
  4. 2002 burban..crank no start after fuel pump install
    By 2oo2ban in forum General Chevy & GM Tech Questions
    Replies: 6
    Last: 11-08-2010, 04:26 PM
  5. '06 Sierra no start - fuel pump
    By RAMwoodworks in forum General Chevy & GM Tech Questions
    Replies: 3
    Last: 04-18-2010, 09:43 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •