GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 Last Post byLast Post by
Results 1 to 10 of 16
  1. #1
    Newbie
    Join Date
    Feb 2012
    Location
    Cuyahoga Falls, OH
    Posts
    6

    Default Thermostat issue (?) on a girls '00 Silverado 1500

    Hey everybody! I have a 2000 Silverado 1500 with 216k miles on it. When I was driving from Columbus, OH home yesterday (2 hour drive that took me 3.5 hours), my engine temp gauge hit red after a short time (half hour) of driving. When I turned my heat on full blast, the temp went down, but not very much. My friend and I both think its the thermostat, but what do you think? When I drove it today (7 miles down the road), it was almost to red after the short distance. The coolant is at the right level, and I dont see any leaks anywhere. If I need to replace it, do I need to drain it completely or just enough so its out of the thermostat housing? Thanks so much for your help!
    ~Nikki~

  2. #2

    Default

    Nikki you need to check the oil for traces of antifreeze in it, if antifreeze is in your oil the oil will be the color of mud.
    I suspect you probably have a bad head gasket and continued running of the engine will only make things worse.
    If you havent already done so check the coolant level to ensure proper quantity.

  3. #3

    Default

    Hi Nikki!

    It could be the thermostat or water pump. If the impeller is worn down on the water pump, it can't move water through the engine. Drain the coolant into a pail and look for an oil slick on top of it. It will be all rainbow colored in the sunlight. take the thermostat out (on the engine end of the upper radiator hose) and toss it into a pot of water. Put the pot of water on the stove and heat it up to boiling. The thermostat should open up just before the water starts to boil.

    If it opens properly (and I suspect that it will), then that is not your problem. Given the details you posted, I am guessing that your water pump needs to be replaced. The other concern is "Stop Leak" product... Have you ever used any stop leak? What color is your coolant? It should be bright green (or orange/red if you are using dexcool.) On that note... Have you ever added any coolant? Did you mix regular antifreeze with Dexcool? If you did, that is likely your problem. When you mix them, it causes the coolant to coagulate and turns your coolant into goo with the consistency of Jello. That would also cause your problem.

    NEVER mix green and any other color unless the jug clearly states that it mixes with other kinds!

    Let us know more about the truck and what you find.
    Last edited by moogvo; 04-10-2012 at 12:15 PM.
    "It went together didn't it? Well then there has to be a way to take it apart!" - Me.

    Check out my image gallery HERE.



    "The true measure of a man is how he treats someone who can do him absolutely no good." ~Samuel Johnson (1709-1784)

  4. #4
    Newbie
    Join Date
    Feb 2012
    Location
    Cuyahoga Falls, OH
    Posts
    6

    Default

    Hey! I actually just had the water pump changed 2 months ago, so it should still be OK, but I will take a look at it. I do have the dexcool in it, and have only ever added that kind to the truck. I just bought a jug that says it can mix with any color, but have not added anything to the truck since the reservoir is at the proper level. I guess my next step is testing the thermostat! Anything else that it could possibly be? Thank you so much!

  5. #5

    Default

    I still suspect the water pump. I have seen MANY of them fail out of the box, especially if it is one of those $20.00 parts. Once you get this problem sorted out, get that dexcool out of there! Flush it REAL good and put the "mix with any kind" back in. Dexcool eats seals and causes blown intake gaskets!

    In any case, test your thermostat and let us know how that works out. For it to overheat so quickly, I am betting that there is either no circulation or perhaps the sensor is bad, reporting that it is overheated when in fact it is not. Something you might try before you go ripping the thing apart is to have someone to hook it to a scan tool and read the data for the coolant temp sensor. Reading the computer may show that it isn't overheating at all. My '03 would take a notion to run the gauge all the way into the red at random. It would normally drop right back down after a few seconds. With mine, it was a bad stepper motor in the cluster... a known issue with these. If you can read the computer data, you will see the true readings.

    Did the truck start to run any differently when this happened? I am beginning to suspect that it is not overheating...

    By the way, AWESOME that you are working on your own truck... or at least being proactive if someone else is doing the work. A BIG thumbs up to you! (My wife needs to be friends with you! LOL!)
    Last edited by moogvo; 04-10-2012 at 12:43 PM.

  6. #6
    Newbie
    Join Date
    Feb 2012
    Location
    Cuyahoga Falls, OH
    Posts
    6

    Default

    The truck still ran the same- no differences in feel or anything, just the gauge. The air coming out in the cab (since I had the heat cranked with the windows down) did smell different- kind of sweet maybe. I can take it down to a local shop and have them hook it to a scanner hopefully tomorrow. As far as it not being overheated, it stayed in the red (or the line right before red) for the whole drive (3+ hours), so I'm not sure as to what it is exactly. I will take the thermostat out tomorrow and test it as well- sounds like an easy test!

    I like to at least try to do all my own work on my truck. If I cant do it, I still want to watch and figure out how it all works! Garages are so darn expensive to have them doing everything! Thanks for all of your help! I really appreciate it! (its so hard for a girl to get help around my parts- all the guys at my college just jump right in when I am the one wanting to learn! The hood goes up and the guys come out to play! Typical! LOL)

  7. #7
    Jr. Mechanic LB'07-Z's Avatar
    Join Date
    Aug 2011
    Location
    Holly Pond, AL
    Posts
    108

    Default

    I had extremely similar symptoms in my '90 Silverado several years ago and it was the thermostat.

    Luke
    '02 Chevrolet 2500hd
    6.6 Duramax LB7
    3.5" Straight Pipe
    4" MBRP Black Exhaust Tip
    Tow Mirrors
    TSC Black Low Profile Tool Box
    Maverick Brush Guard




  8. #8

    Default

    Welcome to the GMTC Nikki, My bet is the thermostat, they should be changed every year and almost no one does it. Also they are cheap and easy to change. Just don't get the standard or cheap thermostat, get the good one with the lifetime warranty. If they stick they are supposed to stick open not closed. I also agree you should drain, flush thoroughly and refill with 1 gallon green antifreeze and then top off with water. Good luck.
    Last edited by donyms; 04-10-2012 at 02:36 PM.


    2002 Chevrolet Silverado Extended Cab SportSide: See Mods in My Garage

  9. #9

    Default

    We are the Borg. Lower your truck and surrender your keys. We will add your biological and technological distinctiveness to our own. Resistance is futile. Erm, I mean ... as you seem to have your answer, welcome to GM Truck Club!

  10. #10

    Default

    Welcome to the site Nikki. I'm sure GMCErica will get in touch with you soon to add to the Girl's club. Looks like you're getting some help already and I don't have anything more to add to it at this point. I do look forward to seeing some pics of your truck though. Good to have you around.

    To Be Completed (Eventually):
    6" BDS Suspension lift | KingShocks Front and Rear Coil Overs | 4.56 Gears | 35" A/Ts (TBD) | Cervinis 07-12 Silverado Ram Air Hood | Fab Fours Front Winch Bumper (CS07-H2051-1) | Fab Fours Full Size Rear Bumper (CS07-W1850-1) | RX-2 Series Main Grille (Black) | Line-x Bed and wheel wells | Skid Plates | Rizor Automated Tonneau Cover | Custom Bed Insert | RBP RX-3 Series Nerf Bars | Kenwood Excelon DNX9990HD | JL Audio Stealthbox (2x500RMS) | JL Audio HD 1200/1 Class D Mono Amp | JL Audio C5-653 Components (Front) | JL Audio C5-650 Components (Rear) | JL Audio Slash v2 300/4v2 Class A/B Amp

Page 1 of 2 12 Last Post byLast Post by

Similar Threads

  1. 2001 Silverado 1500 with issue
    By Boostedman in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 2
    Last: 06-24-2011, 04:57 PM
  2. Do I need a thermostat on my Silverado? Help! :)
    By Chevy04 in forum General Chevy & GM Tech Questions
    Replies: 7
    Last: 03-03-2011, 11:49 AM
  3. NEW 160 Degree Thermostat Camaro Silverado Corvette LS1
    By ChevyFan in forum Chevy Parts eBay
    Replies: 0
    Last: 02-25-2011, 06:20 PM
  4. Hypertech THERMOSTAT chevrolet SILVERADO 1500 part 99
    By ChevyFan in forum Chevy Parts eBay
    Replies: 0
    Last: 07-17-2010, 05:30 PM
  5. Hypertech THERMOSTAT chevrolet SILVERADO 1500 part 99
    By ChevyFan in forum Chevy Parts eBay
    Replies: 0
    Last: 06-23-2010, 11:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •