GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4
  1. #1

    Default Troubleshoot 96 chevy 1500

    Two days ago truck was ok. But this weekend i needed to drive an hour to work and back both sat and sun. Total milage probably around 240 or 250. At the end of today getting off the highway, as she shifted fron first to second (automatic), she gave a kick then drove normally. Then i stopped, and then accelerated, and she gave another kick going from first to second. After this i also noticed my "service engine soon" light was on. Can anyone give me a clue about what could cause this?

  2. #2
    Sr. Apprentice
    Join Date
    Jan 2012
    Location
    Sault Ste. Marie, Ontario Canada
    Posts
    72

    Default

    Lets start off with the basics. What codes are you getting? The codes themselves may help determine the problem. A local AutoZone or PepBoys will be more than happy to scan the codes for you, for free.

    Are you sure it is shifting into 2nd gear, and not dropping into 3rd causing the "kick" you are feeling? The problem you're describing sounds like the sun-shell in your transmission may be worn out. I had a similar feeling symptom over a year ago. It felt like the transmission was shifting very hard into 2nd gear, and the RPMs and speed were slow to build. I also noticed a bit of hesitation in reverse. On the 4L60Es, the stock sun-shell is very weak, and when it wears out you lose 2nd, and 4th (OD) gear. You effectively only have 1st, 3rd and Reverse.... and it feels like the transmission is holding the gear for longer than normal and then shifting. When in fact, its not shifting hard at all.. its skipping a gear. You didn't mention what kind of milage is on your '96.

    If it is your transmission... make sure that your rebuild or replacement uses a "Beast" Sun-Shell. ALL respectable transmission shops use these sun-shells to address the problem with the stock design. If they don't use a BEAST sun-shell, look for a shop that does. $800-$1300 is the going rate for a 4L60E. Price variation accounts for kevlar clutch packs, corvette servo, shift kit. $1300 should get you all of what was mentioned -- and plenty strong to handle up to 450HP before a more "serious" rebuild is needed.
    My lug nuts require more torque than your Honda makes.

  3. #3

    Default

    Ok guess i will start with the codes.
    She only kicks when accelerating from first to second.
    She has 150000 miles, i checked the tranny fluid when i parked that day, following the procedure in my owners manual, and the fluid seems to be overfilled to me. Could having too much fluid have this kind of effect on a transmission? I drove her a short distance around town the last two days, no highway travel, and she drove normally both days. Tomorrow i have another long ride so we will see if she acts up again.
    If the problem does turn out to be a sun shell, how long do i have before my tranny becomes junk?

  4. #4
    Sr. Apprentice
    Join Date
    Jan 2012
    Location
    Sault Ste. Marie, Ontario Canada
    Posts
    72

    Default

    150,000 miles is a bit on the high side for a stock 4L60E. Mine bit the bullet at about the same time... give or take 5,000 miles. It happened exactly as you describe. It worked fine one day, and then the next day it was weird. Can you describe the "kick" a bit more? How many shifts do you "feel"? ... (try to pay attention to it..put the transmission in D, not over drive. Accelerate slowly... up to 60 mph. You should feel two shifts... 2nd and then 3rd.)

    If your truck only gives you one hard shift from 1st to 2nd... and you don't feel the third shift at all; your transmission is toast. You're running on borrowed time as is -- and you need to rebuild or replace it. Plainly put.. if it is the sunshell.. the tranny already _IS_ junk.
    Last edited by Strino78; 04-19-2012 at 12:38 PM.
    My lug nuts require more torque than your Honda makes.

Similar Threads

  1. Replies: 1
    Last Post: 08-17-2011, 03:47 PM
  2. 4L80E rebuild/troubleshoot
    By meby in forum GM Powertrain
    Replies: 0
    Last Post: 08-17-2011, 11:36 AM
  3. Replies: 0
    Last Post: 11-26-2009, 01:20 AM
  4. help troubleshoot brakes 93 chevy 1.2 ton
    By regal557 in forum Lifted & Offroad Suspension
    Replies: 5
    Last Post: 07-18-2009, 09:43 AM
  5. How to troubleshoot 4WD in a 2001 Suburban
    By raydium in forum GM Powertrain
    Replies: 4
    Last Post: 05-29-2009, 06:05 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •