GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 LastLast
Results 1 to 10 of 18
  1. #1

    Default Ac/heater not working

    Hey what's up guys/ladies, I am here with my issue of the week lol my heater/ac isn't working all that well and I have no idea why. It seems to start blowing once the truck warms up but still not very heavily, like almost non-existant. Anyone know why? I thought maybe the AC just needed to be recharged but as far as I know that wouldn't affect the heater. Help please!!!!!!!! Oh and it's a 05 Silverado with the 5.3. Worked fine when I bought it.

  2. #2

    Default

    It could be your in-cab air filter is plugged up but I'm no genius but thats where I would look.



    If at first you don't succeed, chances are, you are using too small of a cheater bar

    Current:
    1999 GMC Sierra SLT Z71 | 5.3 Vortec | Spectre Cold Air Intake | TransDapt TBS | Hypertech 30005 Tune | 2005 Chevy Tails | Denali headlights | AWS Bug Shield | 265/75/16 Mastercraft Courser A/T | "Ghetto" painted tailgate | Boss HD Speakers | 2005 Overhead Console | Dual Thrush Turbo Mufflers
    Future:
    Bigger Amp Alternator | Electric Fans | Oil/Trans Fluid cooler | Re-done exhaust | Paint | Interior Restoration/upgrade with newer model stuff | Window Visors (In channel) | Tint | Low-Profile Tool Box | LEDs throughout stock cab locations | And whatever is spurr of the moment
    US Navy Sailor :sign0011:

  3. #3

    Default

    where is that?

  4. #4

    Default

    Under the glove box. I'll see if I can't find a picture



    If at first you don't succeed, chances are, you are using too small of a cheater bar

    Current:
    1999 GMC Sierra SLT Z71 | 5.3 Vortec | Spectre Cold Air Intake | TransDapt TBS | Hypertech 30005 Tune | 2005 Chevy Tails | Denali headlights | AWS Bug Shield | 265/75/16 Mastercraft Courser A/T | "Ghetto" painted tailgate | Boss HD Speakers | 2005 Overhead Console | Dual Thrush Turbo Mufflers
    Future:
    Bigger Amp Alternator | Electric Fans | Oil/Trans Fluid cooler | Re-done exhaust | Paint | Interior Restoration/upgrade with newer model stuff | Window Visors (In channel) | Tint | Low-Profile Tool Box | LEDs throughout stock cab locations | And whatever is spurr of the moment
    US Navy Sailor :sign0011:

  5. #5

    Default

    Click image for larger version. 

Name:	cockpit.jpg 
Views:	299 
Size:	9.9 KB 
ID:	38181

    Since I'm not good with photoshopping and computers in general, its under the glove box right where that black 3 pronged looking piece is.



    If at first you don't succeed, chances are, you are using too small of a cheater bar

    Current:
    1999 GMC Sierra SLT Z71 | 5.3 Vortec | Spectre Cold Air Intake | TransDapt TBS | Hypertech 30005 Tune | 2005 Chevy Tails | Denali headlights | AWS Bug Shield | 265/75/16 Mastercraft Courser A/T | "Ghetto" painted tailgate | Boss HD Speakers | 2005 Overhead Console | Dual Thrush Turbo Mufflers
    Future:
    Bigger Amp Alternator | Electric Fans | Oil/Trans Fluid cooler | Re-done exhaust | Paint | Interior Restoration/upgrade with newer model stuff | Window Visors (In channel) | Tint | Low-Profile Tool Box | LEDs throughout stock cab locations | And whatever is spurr of the moment
    US Navy Sailor :sign0011:

  6. #6
    Legend


    Enkeiavalanche's Avatar
    Join Date
    Apr 2010
    Location
    Piermont,NY, back in Northern NJ now, But may be in IL soon....
    Posts
    5,319

    Default

    It's a 05 he does not have one... Does it work at high speed , Like the last 2 clicks on the fan control?
    08 Z71 Avalanche Mods to date: K&N CAI,Hellwig Swaybars and End Links, Corsa Sport Exhaust, Superchips Programer,IPCW LOF & 3rd brake light and tails, AMI Gas door,Show Hooks and Door locks, Enkei Wheels, with Pirelli tires, StreetScene Bowties, Grant Steering wheel,Muth signal mirrors,SSBC Big Brake kit,Huskyliner Mug gards,Floor mats and Hood shield, McGard Lug nuts and locks, Bedrug, Cervini's Ram Air hood,35watt HID Fog lights, Sylvania bulbs all around ZXE's Highs and Lows, WhiteNight Back up lights,Sirius and HD Radio, SnugTop sitting on deck now Got a Softopper on now,Tempress Boat Hatches.... New Bilstein shocks are on... New Mods coming soon..... X

  7. #7

    Default

    Quote Originally Posted by Enkeiavalanche View Post
    It's a 05 he does not have one... Does it work at high speed , Like the last 2 clicks on the fan control?
    Chances are that the resistor for the fan is bad. My 02 did the same thing. No lower fan speeds only high. Depending on the controls you have they can range from $30 to $100. Pretty easy to change out also.

    1995 Silverado 4x4
    6" BDS Suspension Lift-3" Body Lift-Add A Leaf in rear -Trailmaster SSV Shocks-Duel Steering Stabilizer Kit -AirAid Cold air intake-
    4.56 Gears with Detroit Auburn Locker-Pro-Comp Traction Bars with duel shocks-Aluminum Skid Plate Kit-38.5" x 16.5" Mickey Thompson Baja Claws-Constant Dropping fuel gauge

    2005 Yukon XL Jet Power Programmer, Bilstein Shocks, Bilstein rear springs, Helwig Anti-sway bars, EGR Window Visors, EGR Hood Shield, Denali Headlights, Headlight harness upgrade, GE NightHawk Bulbs, White Night Rear lighting system, Russell Braided SS brake lines, PowerStop Brake pads, PowerStop cross drilled and Slotted Rotors, http://www.gmtruckclub.com/forum/sho...5-GMC-Yukon-XL
    2002 Silverado ext cab 2wd (Sold)
    2003 Yukon XL (Totaled)

  8. #8
    Jr. Engineer UpsetProps's Avatar
    Join Date
    Mar 2012
    Location
    Calgary, Alberta, Canada
    Posts
    219

    Default

    I know the 07's had a recall on either the blower motor itself or its control module. If you bought it brand new and it had the recall you should have received something in the mail about 1.5years ago. (That's when I got the notice for my 07).

    If you bought it used perhaps just call a dealership and ask if there was a recall on that model year.

    2012 Silverado 1500 LS Crew Cab 4.8L 4x4
    - Nitto Tera Grapler 265/70R17, Line-X bed liner, Black Bowties, Stampede front deflector, DeeZee black diamond plate bed rails, TonnoPro Lo-roll cover, Antenna deleted, Spyder Projection Headlights with Phillips CrystalVision Ultra bulbs, Spyder Tail Lights & 3rd Brake Light, Rough Country leveling kit, PlastiDip'd emblems, and wheel hubs, Diablosport Trinity, 20% tint, Black OEM grill


    "Coming through in a new Chevy, droppin' game like it's too heavy."

  9. #9
    Legend


    Enkeiavalanche's Avatar
    Join Date
    Apr 2010
    Location
    Piermont,NY, back in Northern NJ now, But may be in IL soon....
    Posts
    5,319

    Default

    Quote Originally Posted by Pikey View Post
    Chances are that the resistor for the fan is bad. My 02 did the same thing. No lower fan speeds only high. Depending on the controls you have they can range from $30 to $100. Pretty easy to change out also.

    Thats what I was thinking too.. Changed mine in my o2 also.. Easy fix And If I remember the part was cheap about $30.00
    08 Z71 Avalanche Mods to date: K&N CAI,Hellwig Swaybars and End Links, Corsa Sport Exhaust, Superchips Programer,IPCW LOF & 3rd brake light and tails, AMI Gas door,Show Hooks and Door locks, Enkei Wheels, with Pirelli tires, StreetScene Bowties, Grant Steering wheel,Muth signal mirrors,SSBC Big Brake kit,Huskyliner Mug gards,Floor mats and Hood shield, McGard Lug nuts and locks, Bedrug, Cervini's Ram Air hood,35watt HID Fog lights, Sylvania bulbs all around ZXE's Highs and Lows, WhiteNight Back up lights,Sirius and HD Radio, SnugTop sitting on deck now Got a Softopper on now,Tempress Boat Hatches.... New Bilstein shocks are on... New Mods coming soon..... X

  10. #10

    Default

    To answer your guys' questions no it doesn't blow more at higher speeds, I've got it set on full blast and I barely have anything coming out the vents. I sort of think it's the blower, I can hear a bit of a whining/ groaning noise when I turn the air off then back on again.

Page 1 of 2 12 LastLast

Similar Threads

  1. Newbie: 93 GMC Suburban Heater/AC control is not working.
    By @ChrisBrown201 in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 02-06-2011, 10:16 AM
  2. Coolant flush now heater not working well
    By Mtrotter in forum General Chevy & GM Tech Questions
    Replies: 4
    Last Post: 03-10-2010, 04:21 PM
  3. heater not working!!
    By wilk in forum General Chevy & GM Tech Questions
    Replies: 13
    Last Post: 03-07-2010, 08:02 AM
  4. heater not working
    By henrys021500hd in forum GM Electrical Tech
    Replies: 3
    Last Post: 01-28-2010, 01:43 PM
  5. heater/vents not working, only blowing to floor
    By thattallguy32 in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 10-12-2009, 12:50 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •