GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6

Thread: please help!!!

  1. #1

    Default please help!!!

    so i have an 03 2500 crew cab LT with the factory rear entertainment system. i upgraded the front radio with a kenwood dnx6960. i have the bose system so i installed the pac radio OS-2BOSE wiring harness, but in doing so i lose the functions of the rear entertainment. has anyone had something similar done or know a way to get those functions back. thanks

  2. #2

  3. #3

    Default

    You might try the Audio / Video Electrical section of the forums; probably more audo/video-savvy people reading that section of the forums.

  4. #4

    Default

    It might not be completely compatible even with harness. It has been a long time since I have worked at a place installing, I’m sure some things have changed. Sometimes it is just one or two wires that need spliced. I would truly suggest contacting customer support by phone or by email. When they ask if you tried the online manual just say all day.
    Tim Walters (Curky)

    Wrangler AT/S 265/70R17 - Trail-FX window vents - Husky fitted splash guards - Silver Star zXe - Leveling kit -

  5. #5

    Default

    Quote Originally Posted by Curky View Post
    It might not be completely compatible even with harness. It has been a long time since I have worked at a place installing, I’m sure some things have changed. Sometimes it is just one or two wires that need spliced. I would truly suggest contacting customer support by phone or by email. When they ask if you tried the online manual just say all day.
    i called pac tech support today, (not very bright people), at least the guy i talked to) he said the only way is to somehoe retrofit in the factory radio in somewhere, yea thats not happening. ill try to fiddle with it this weekend and go back and forth between my factory radio and aftermatket, and try to pinpoint which wires power up the rear radio. and just go from there.
    if anyone knows of someone or has found a write up on how to do it please let me know.

  6. #6

    Default

    Quote Originally Posted by R6 Tech 413 View Post
    i called pac tech support today, (not very bright people), at least the guy i talked to) he said the only way is to somehoe retrofit in the factory radio in somewhere, yea thats not happening. ill try to fiddle with it this weekend and go back and forth between my factory radio and aftermatket, and try to pinpoint which wires power up the rear radio. and just go from there.
    if anyone knows of someone or has found a write up on how to do it please let me know.
    That is exactly how you need to do it (find what wire is not connected. Then you need to find out what that wire does. Worse case call a car audio place, tell them your problem and find out how much it would cost them to hook it up. (Since it is a expensive radio, take it to a reputable place) They are use to this stuff. Sometimes spending a couple of extra buck is better than the headache. As well, if they screw something up it is covered.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •