GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 Last Post byLast Post by
Results 1 to 10 of 12
  1. #1

    Default 4x4 problem 89 chevy

    i recently bought an 89 chevy 1500 that the guy had used as a mud truck. the 4x4 was not working and its still not. i know the transfer case engages. i just replaced the actuator. what else is there to stop it from working? i cant figure it out. im a jeep guy not a chevy so im not too familiar with them. thanks.

  2. #2
    Master Mechanic Jimmeh's Avatar
    Join Date
    Apr 2009
    Location
    Columbia Falls, Montana, United States
    Posts
    806
    Blog Entries
    3

    Default

    Did you replace it with a used actuator?

    I recommend installing one of these instead of replacing the electronic actuator (http://www.4x4posi-lok.com/app_chevy-k.html).

    I had one installed on my old Dodge and worked absolutely great! Installation wasn't too bad either (think it took me about an hour, maybe two).
    2005 Chevy Silverado W/T
    4X4|4.8 with some mods (has only slightly more pull than a 5.3)|Auto|4 door ex cab|Cooper Discoverer AT/3's in 285-75/17's on Helo 842's|Cooper Discover M+S 265-75/17's on Devino DV349's|Flowmaster 40 Single in Dual out with custom bent pipe from the end of the cats back|2" Procomp leveling kit|Custom made center console|Custom dyno tunes|Air Raid CAI|Air Raid Throttle Body Spacer|Apex brand topper|Kenwood Head Unit with Kenwood speakers|Painted mirrors/grille|Debadged except front emblem|Bilsteins front and rear
    Planned mods not in order
    2 inch lift|Custom front/rear bumper|hitch tire carrier|roof basket on topper, bars on cab|finish center console build|install Midland CB|Power options|Tint|Custom made raised bed in the bed of the truck|Lund LunarVisor
    Also have a 1992 Ford Ranger with a lot of stuff done to it. Currently waiting for a bit of a rebuild.


    "The only woman I'm pimping from now on is Sweet Lady Propane. And I'm tricking her out all over this town."

  3. #3

    Default

    i replaced it with a new one. i know the transfer case works. i cant figure out what the problem is. what other parts are there to do with 4wd? i know the fuse is good on the fuse box

  4. #4
    Master Mechanic
    Dirty Dog's Avatar
    Join Date
    Mar 2012
    Location
    Regina Saskatchewan Canada
    Posts
    731
    Blog Entries
    31

    Default

    Quote Originally Posted by abadoobi View Post
    i replaced it with a new one. i know the transfer case works. i cant figure out what the problem is. what other parts are there to do with 4wd? i know the fuse is good on the fuse box
    Ok have you seen your front drive shaft actually turn,,, if it was used for mudding as you say it could be a number of things, I have a couple 95s here, but they are floor shift models, so I will need a little more info to make any worthy suggestions,, but the first thing that comes to mind,, is the front diff gears are not meshing..... Jack up one side of the front end and put in four wheel drive turn the front wheel by hand and listen for strange noises....that would be a good place to start....

  5. #5

    Default

    i havent actually seen the shaft turning but i did put the front drive shaft back on and i put it in 4wd to tighten the bolts so the shaft would not turn. its and 89 with a 350 700r4 np241. its floor shifted. i can try that but are there any other parts that put it in 4 wheel drive?

  6. #6
    Master Mechanic
    Dirty Dog's Avatar
    Join Date
    Mar 2012
    Location
    Regina Saskatchewan Canada
    Posts
    731
    Blog Entries
    31

    Default

    ok so the front drive shaft is connected, you are in four wheel drive right?... and the drive shaft is tight when you try to turn by hand(park) Try in neutral , and then check it with one tire in the air, in gear, neutral and park, by spinning raised tire, listen for strange noises in the front diffy... there are only so many parts and pieces, if your shifter is engaging and your wiring is correct, you are looking farther down the line for problems, diffy /axils/ hubs.....I know on my old 92 it would take a few feet(rotations of the tire) to actually kick into four wheel drive, ( i am thinking that was the truck near the end of its days we actually had to back up dam near half a mile to get it out of four wheel drive that truck was used hard off road)....it doesn't have crazy hubs on the front ? like warn auto lockers or something to that affect?

  7. #7

    Default

    it all appears to be stock. im going to try a new fuse. it didnt look busted to me but i dont know what else the problem could be. there is another wiring harness going to the front diff. im not sure what it is and it doesnt seem to unplug from the diff. i have not had time to jack it up turn it around yet but im pretty sure there are no noises coming from it. i cant hear any noises coming from the truck when i drive it but it is VERY loud. what would the hubs have to do wit h4 wheel drive working?

  8. #8
    Master Mechanic
    Dirty Dog's Avatar
    Join Date
    Mar 2012
    Location
    Regina Saskatchewan Canada
    Posts
    731
    Blog Entries
    31

    Default

    a lot of us used to change out the stock and mod them for mudding, and pit runs,,, you mentioned he mudded with it,, so chances are he had some big tires and all and could have done some mods,, and hubs were cheaper to replace the diffys,,, any ways check all the wiring again thats a good first step.... I am off now hope it works out,, let us know what you found out.....

  9. #9

    Default

    Stock hubs were probably the auto locking hubs, and we just replaced ours on our 89 Blazer because they wouldn't engage or disengage easily.

    How are you testing the 4wd? How did you determine it wasn't working?

    I think what Dog is saying is that you have manually engaged your transfer case, which should turn the front shaft. If you aren't getting power to the tire, then either diff gears have an issue or the hubs.

    Were these transfer cases chain driven?
    Mark
    89 K Blazer 4" lift 35x12.5x15, warn hubs, cut out flares. Soon to have headers, posi carriers, gears.
    2000 K2500 Crew Cab 5.7 285/75R16's. 3" Body lift. Suspension parts being ordered.
    Lots more to do on both the trucks

    And a bunch of fast Buicks

  10. #10

    Default

    i think they are chain driven but im not positive. if the diff gears have a problem you would hear them grinding though correct? how can i check if its the hubs. this thing is diving me nuts

    ---------- Post added at 10:54 AM ---------- Previous post was at 10:49 AM ----------

    they are auto locking hubs. i wish they were manual hubs. my life would be a lot easier

Page 1 of 2 12 Last Post byLast Post by

Similar Threads

  1. 87 Chevy R10 problem
    By airbornehodges in forum The Coffee Shop ~ Chit Chat
    Replies: 0
    Last: 12-23-2011, 10:40 PM
  2. 94 Chevy Problem
    By GuajoloteMenor in forum General Chevy & GM Tech Questions
    Replies: 2
    Last: 08-11-2011, 09:07 PM
  3. 94 Chevy Problem
    By GuajoloteMenor in forum Chevy Truck Talk & GM News
    Replies: 7
    Last: 07-28-2011, 01:41 PM
  4. 96 Chevy tahoe problem fuel problem? Need help ASAP!
    By Fear58 in forum General Chevy & GM Tech Questions
    Replies: 5
    Last: 12-13-2009, 05:38 PM
  5. Chevy pic, but i have a oil problem
    By REV22 in forum Chevy C/K Truck Forum
    Replies: 7
    Last: 04-13-2009, 09:24 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •