GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4
  1. #1
    Master Mechanic
    Join Date
    Apr 2009
    Location
    Owens Cross Roads, Alabama
    Posts
    634

    Default "Service Brake System" message

    Recently, my truck has been giving me the Service Brake System message when i start my truck up. I can immediatley turn the truck off and then back on and it will go away. Just to be on the safe side, I have replaced all 4 rotors and all brake pads, but still get the message.
    Anybody know what else could be causing this? Bad sensor? It's driving me INSANE!
    -Dylan
    2004 Silverado 4x4
    4.8L
    1986 K5 Blazer
    8" Superlift w/39.5 super swampers
    1992 GMC Jimmy "Blue Bomber"
    4.3L Vortec

  2. #2

    Default

    I would say it has something to do with the ABS brake system, considering it's the only computerized component in a brake system. You want to pull the code with a reader; it will most likely need to be an ABS-specific coade reader. Find out what the code says, and go from there.
    Christopher

    1991 Chevy Suburban 1/2 ton 2WD w/ chevy SBC 350-3/4 ton drivetrain upgrade w/4.10 gears 200K miles
    2005 Saturn ION-2 Stock 265K miles
    1982 Bronco, 1993 Bronco (sold), 1971 M35A2 Deuce and a Half



    There are 10 kinds of people, those who understand binary, and those who dont...

    Remember kids, the only difference between screwing around and science is writing it down- Adam Savage

  3. #3
    Jr. Engineer UpsetProps's Avatar
    Join Date
    Mar 2012
    Location
    Calgary, Alberta, Canada
    Posts
    219

    Default

    I had this light come on in my 2007 when driving down the road occasionally or when trying to roll up 2 windows at once.

    The problem was some grounds on the frame that needed to be cleaned. It was a common problem on some of the 04-07 Silverados I believe.
    Last edited by mfleetwood; 05-10-2012 at 10:19 PM.

    2012 Silverado 1500 LS Crew Cab 4.8L 4x4
    - Nitto Tera Grapler 265/70R17, Line-X bed liner, Black Bowties, Stampede front deflector, DeeZee black diamond plate bed rails, TonnoPro Lo-roll cover, Antenna deleted, Spyder Projection Headlights with Phillips CrystalVision Ultra bulbs, Spyder Tail Lights & 3rd Brake Light, Rough Country leveling kit, PlastiDip'd emblems, and wheel hubs, Diablosport Trinity, 20% tint, Black OEM grill


    "Coming through in a new Chevy, droppin' game like it's too heavy."

  4. #4
    Sr. Engineer
    Join Date
    Dec 2011
    Location
    11-22-boogie woogie avenue
    Posts
    308

    Default

    Try disconnecting battery for 10 minutes see if it comes back.
    RESIDENT NUT.....MY CLAIM TO FAME .....

Similar Threads

  1. Replies: 8
    Last Post: 10-19-2011, 03:47 PM
  2. "Service Brake System" accompanied by SERIOUS truck freakout. PLEASE help us!
    By theclicks in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 5
    Last Post: 01-08-2011, 12:06 AM
  3. 2001 suburban with "service 4wd" on dash message light
    By junktrux in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 1
    Last Post: 10-28-2010, 04:58 PM
  4. 1999 Silverado - "Security" message stays on
    By Gotechslack in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 5
    Last Post: 03-25-2010, 03:02 PM
  5. 03 "Service 4 wheel drive" message
    By 03z71ls in forum Member Introductions
    Replies: 11
    Last Post: 09-26-2009, 12:09 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •