GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 3 123 Last Post byLast Post by
Results 1 to 10 of 26
  1. #1
    Jr. Engineer
    Join Date
    Dec 2008
    Location
    south florida
    Posts
    239

    Default cruise control not working

    guys,
    the cruise control on my 1990 k-1500 4x4 is not working. ever since i had the truck, the resume/accelerate has never worked, but i could at least set it and cruise, or press the side button to slow down.
    now nothing works.
    i checked for a cruise control fuse under the drivers dash fuse panel, but didnt find one, and besides all of those fuses are good anyway.
    is there a fuse somewhere else maybe under the hood for the cruise control ?
    or what else should i check ?

    thanks much guys.

  2. #2

    Default

    I believe there are 4 wires coming off the column for the cruise control. With the key on look for one to be hot. If not look for problem towards fuse / conv center. If you got one hot, hit on the cruise and there should be a second hot. If not = bad switch. If now 2 hots there, check brake pedal switch for hot from there. Should be two SW there and on older ones a vac SW. It should be easy to see which is which. Lots of those switches went bad and there was a recall for some while. If all that is good, you have problems with controller, or ecm info, etc. Not a common issue.More than likely you have a bad switch.
    Last edited by ChevyBoy2009; 05-06-2012 at 04:23 PM.

    2009 Chevrolet Silverado 1500 LT Z71 Crew Cab "All-Star Edition"

    Line-X'd Bed
    Line-X'd Custom Brush Guard(Heavy Duty)
    5.3L Flex Fuel
    275/65R18 Toyo Open Country AT2's
    2" Rough Country Leveling Kit(want to get the 2.5 RC kit)
    EGR In-Channel Vent Visors
    Exterior PLUS Package
    Interior PLUS Package
    K&N Drop-In Air Filter
    ProFlaps
    Cat-Back Dual Exhaust
    Black Bowties
    Diablo Sport Predator(AFM Disabled)
    ProFlaps
    Towing Mirrors
    Next Planned Mods
    Blacked out Tail Lights
    Aftermarket Rims

  3. #3
    Jr. Engineer
    Join Date
    Dec 2008
    Location
    south florida
    Posts
    239

    Default

    Quote Originally Posted by ChevyBoy2003 View Post
    I believe there are 4 wires coming off the column for the cruise control. With the key on look for one to be hot. If not look for problem towards fuse / conv center. If you got one hot, hit on the cruise and there should be a second hot. If not = bad switch. If now 2 hots there, check brake pedal switch for hot from there. Should be two SW there and on older ones a vac SW. It should be easy to see which is which. Lots of those switches went bad and there was a recall for some while. If all that is good, you have problems with controller, or ecm info, etc. Not a common issue.More than likely you have a bad switch.
    what is the fuse/conv center ?

    what is two SW and Vac SW ?

    to check the brake pedal switch should i use my test light on that switch ?

    also, if it is the cruise control switch, how do i replace that ? do i have to take apart the steering column ?

    thanks

  4. #4

    Default

    The fuse box is what i was referring too and SW means switches...yes use your test light when you check it.Its a pretty simple fix...im pretty positive you have a bad brake switch or cruise control switch.
    Last edited by ChevyBoy2009; 05-06-2012 at 07:52 PM.

  5. #5
    Jr. Engineer
    Join Date
    Dec 2008
    Location
    south florida
    Posts
    239

    Default

    Quote Originally Posted by ChevyBoy2003 View Post
    The fuse box is what i was referring too and SW means switches...yes use your test light when you check it.Its a pretty simple fix...im pretty positive you have a bad brake switch or cruise control switch.
    thanks much... i hope to check it one night after work this week.... will let you know what i find

  6. #6
    Jr. Engineer
    Join Date
    Dec 2008
    Location
    south florida
    Posts
    239

    Default

    Quote Originally Posted by ChevyBoy2003 View Post
    The fuse box is what i was referring too and SW means switches...yes use your test light when you check it.Its a pretty simple fix...im pretty positive you have a bad brake switch or cruise control switch.

    ok guys, especially ChevyBoy2003....

    here is what i found today after work...

    i could not find the wires under the steering column that were from the cruise control, but i tested the 4 wires i could see that were near the end of the cruise control/blinker switch..
    4 wires, blue,brown,green,yellow.
    when key is on, only the blue is hot, when the key is on and the cruise control switch is on the green wire also is hot.
    so that seems to confirm that the switch is good, correct ?

    looked up under the column near the brake pedal, and im telling you i could not find a brake light switch, but did find a square looking black box type of switch that is held onto a beefy bracket with two buttons sticking out, that slides into a catch on the steel bracket. that switch seems to be this, which is a cruise control release switch .
    http://www.rockauto.com/catalog/moreinfo.php?pk=97605

    it has only two wires coming from it, white and green. with the key on or off, and the cruise conrol on or off, i do not have either of the two wires hot.... even with the brake pedal depressed.... does this mean that that cruise control release switch is bad ?

    my brake lights work fine...... i just cant find the brake switch, and was thinking the crusie control release switch was the brake light switch until i found it on rockauto.com.

    when searching napa and autozones website i can not find a cruise control switch....

    so, should i be getting one of the wires going to the cruise control release switch hot ? since i am not getting a hot wire, should i replace that switch ? for 7 dollars its worth a try i assume.... i just dont know how the switch works..... how does it being bad not let the cruise control work ?

    thanks for the help guys.....

    leonard

  7. #7

    Default

    hmm im not 100% positive how it all works...i would replace that since its only 7 bucks,its worth the shot...maybe someone will chime in and tell us how it actually all works....but i imagine that you should be getting one hot....due you have a sagging brake pedal??...a sagging one will not let your cruise control work...hold the pedal up with your foot and see if it engages
    Last edited by ChevyBoy2009; 05-07-2012 at 10:16 PM.

  8. #8
    Jr. Engineer
    Join Date
    Dec 2008
    Location
    south florida
    Posts
    239

    Default

    Quote Originally Posted by ChevyBoy2003 View Post
    hmm im not 100% positive how it all works...i would replace that since its only 7 bucks,its worth the shot...maybe someone will chime in and tell us how it actually all works....but i imagine that you should be getting one hot....due you have a sagging brake pedal??...a sagging one will not let your cruise control work...hold the pedal up with your foot and see if it engages

    thanks chevyboy2003....... nope, the brake pedal is not sagging....i will order that switch and give it a shot.... if anyone else has any thoughts on this please let me know...

    leonard

  9. #9

    Default

    Since it was partially working before, I would say you probably have a bad switch in the stem. You will have to replace the stem (called a turn signal lever). I don't remember the particulars of that model, but sometime around that year, they re-designed the switch so that all you have to do is pull the small cover off the back side of the column (where the stem comes through) and the 4 wire connector is under there. Just unplug the connector and pull the stem straight out. It's that easy IF you have the later design. Otherwise, you have to unplug the 4 wire connector at the base of the column (where it mounts to the dash bracket) and slide out the plastic guide that surrounds the wire going up the column. Tie a fine wire through the hole in the male end of the connector and carefully pull it up and out. The stem just pulls straight out of the column. Tie the wire on to the end of the new wire, and carefully pull it back down and through the base of the column, replace the plastic protector (although many people don't) and plug it back in. It's a 10 minute job, tops.
    Good Luck and God Bless
    Remember that if you're not part of the solution, then you're part of the problem!

  10. #10
    Jr. Engineer
    Join Date
    Dec 2008
    Location
    south florida
    Posts
    239

    Default

    thanks for the help Revredneck... this morning i ordered a new new cruise control shut off switch that attaches to the brake pedal, and will try that first.
    i do see what you are talking about, the column does look like it will come apart in a couple small pieces that seem to be removable on the housing that covers the turn signal. if i do change the cruise / blinker switch its nice to know its pretty easy..
    i will let you guys knwo what i find when i put the new switch in....

Page 1 of 3 123 Last Post byLast Post by

Similar Threads

  1. cruise control not working
    By skimm99 in forum Member Introductions
    Replies: 9
    Last: 01-05-2011, 08:08 AM
  2. Replies: 3
    Last: 12-03-2010, 06:40 PM
  3. Cruise control stopped working on my 2007 Silverado - no warranty left
    By Sportmod5 in forum General Chevy & GM Tech Questions
    Replies: 5
    Last: 11-01-2010, 10:03 AM
  4. Engine light linked to Cruise control not working? Help!! please?
    By Rhizzlebop in forum Chevy Trailblazer Forum (GMC Envoy)
    Replies: 4
    Last: 08-16-2010, 09:20 AM
  5. Cruise Control not working
    By leadpan101 in forum Audio, Video & Gadget Tech
    Replies: 4
    Last: 03-30-2009, 09:21 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •