GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6

Thread: 89 idle issues

Hybrid View

  1. #1

    Default 89 idle issues

    I have an 89 Sierra, 5.7. auto,When I first got it it had very hi idle. I replaced base plate gasket nad idle air control valve. It ran fine for about a week. Now it idles rough , especially in drive with brake on. I have replace plugs, wires, cap and rotor, Fuel filter . No change..any advice appreciated.No service engine light and no vacume leaks that i can find..
    Last edited by k9ulan; 05-12-2012 at 01:01 PM.

  2. #2

    Default

    Update:Changed tps , no change

  3. #3

    Default

    Disconnect your egr and plug up the barb on the carb/tbi. I have this problem with my egr hooked up.
    Old Show Trucks USA conversion
    Custom Paint, interior (Wood grain and leather seats) windows so dark you need a flash light to see me, stock rims, headers, dual exhaust.

  4. #4

    Default

    Sounds like your EGR valve is leaking. First unplug the vacuum line and see if that fixes it. If not, remove the EGR valve itself and see if there is debris around the pintle. You can make a simple block off by cutting a piece of pop can to fit the base of the EGR valve. It will turn on the Check Engine light, but it will get you going.
    Good Luck and God Bless
    Remember that if you're not part of the solution, then you're part of the problem!

  5. #5

    Default

    Thanks for the replies, a little more info. I set the timing to 0 with the timing wire unhooked. Runs great, but, when driven it pngs and detonated terribly, so I have to retard the timing to get it to run ok, but still idles poorly. Is this still pointing to egr? all help appreciated..

  6. #6

    Default

    could also be the engine running too cold and trying to warm up.
    someone said these trucks are engineered to run at 210 so they burn cleaner....
    check how your plugs are burning too. that'll say it right there

Similar Threads

  1. 1996 Tahoe irratic misfire at idle, runs fine off idle and cruise
    By tankdg1 in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 1
    Last Post: 09-17-2011, 06:11 PM
  2. 1994 TBI fuel + idle issues
    By weswins in forum GM Powertrain
    Replies: 1
    Last Post: 07-07-2011, 12:28 PM
  3. 2001 GMC Yukon XL - Brake Issues and Idle problem when wet
    By aljoy1 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 0
    Last Post: 08-14-2010, 08:15 AM
  4. issues with idle
    By BigRed2500 in forum Performance & Fuel
    Replies: 0
    Last Post: 08-29-2008, 10:07 AM
  5. Idle Issues
    By trivers in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 13
    Last Post: 11-17-2007, 01:39 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •