GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1

    Default 96 Suburban Turn Signal Inop, ABS Problems & Convertor Problems

    Hello
    I have a 96 Suburban 2500 4x4 w/7.4L with 138K miles. When I bought it 2 years ago the brakes on the passenger side would cycle the ABS when stopping for the last few feet of the stop. I read that it could be the corrosion buildling on the mount of the speed sensor on the wheel bearing. When I asked a local shop about removing the speed sensor and taking off the corrosion they said that is extremely difficult and that they rather replace the whole wheel bearing. Is it that difficult to remove the sensor or should I just replace it all while it is taken apart? I removed the ABS fuse to eliminate the problem of the brakes chattering and the car pulling to the side, it was also dangerous because it could lengthen the distance to stop.

    Also I just noticed last week the turn signals don't work. WHen I use the turn signal level I don't hear any clicking or see the light on the dash that lets me know they are on. What could this be?

    I also have the hot start issue and want to replace the injectors with the Bosch 4 hole injectors. Is it smart to replace the fuel regulator also or is there a quick test that can be done on it to see if it is working properly? My floor boards get awful hot on long trips pulling the trailer and the heat is coming from the convertors. I am assuming that the engine is getting too much fuel or could it be something else?

    Thanks

    Joe
    99 Suburban 2500 4x4
    06 Explorer Ltd 4x4

  2. #2

    Default

    I believe on those they are a hub assembly. You would be better off just changing bearing. It is 1 unit. As for the turn signal, check the flasher. If you dont hear clicking, check to see if you have power running through the flasher. Try changing that fist. As for the hot floor, if you get a laser temp gauge, check the temp before and after the cat.
    Please Tell Your Boobs To Quit Staring At My Eyes

  3. #3

    Default

    Hey thanks for the response. Where is the flasher located?

    Quote Originally Posted by osgprometheus View Post
    I believe on those they are a hub assembly. You would be better off just changing bearing. It is 1 unit. As for the turn signal, check the flasher. If you dont hear clicking, check to see if you have power running through the flasher. Try changing that fist. As for the hot floor, if you get a laser temp gauge, check the temp before and after the cat.
    99 Suburban 2500 4x4
    06 Explorer Ltd 4x4

  4. #4
    Sr. Engineer
    Join Date
    Dec 2011
    Location
    11-22-boogie woogie avenue
    Posts
    308

    Default

    Location of flasher http://www.gmtruckclub.com/forum/sho...#axzz1usL7MasB
    On the fuel reg. pull vacuum line off ..any fuel present bad. But do not think it is bad .
    Would have a long start issue all times . Are you getting a service engine light?
    Need to scan if so. Also if cat is getting hot probably already bad .
    Any unmetered fuel will ruin quick. I would clean the maf sensor and change coolant temp sensor if no service light.
    Coolant sensor located beside thermostat housing . Maf located in air filter system between filter ,and throttle body.
    RESIDENT NUT.....MY CLAIM TO FAME .....

  5. #5

    Default

    No Check Engine Light. I bought this more than a year ago and put Sea Foam in the tank, used MAF spray cleaner and used TB cleaner in the TB and changed air filter. I only have the long start when it is hot. I only noticed the hot cat on long trip pulling 8.5K trailer and truck loaded up last summer. The last trip recently with trailer when it was 55F the floor didn't get as hot but the other times it was hot to the touch. I do notice the smell of gas occassionally after shut down (after a short time) but didn't know if the plugs were bad, or if it was coming from the induction side from the bad injectors.

    Quote Originally Posted by dipstick View Post
    Location of flasher http://www.gmtruckclub.com/forum/sho...#axzz1usL7MasB
    On the fuel reg. pull vacuum line off ..any fuel present bad. But do not think it is bad .
    Would have a long start issue all times . Are you getting a service engine light?
    Need to scan if so. Also if cat is getting hot probably already bad .
    Any unmetered fuel will ruin quick. I would clean the maf sensor and change coolant temp sensor if no service light.
    Coolant sensor located beside thermostat housing . Maf located in air filter system between filter ,and throttle body.
    99 Suburban 2500 4x4
    06 Explorer Ltd 4x4

  6. #6

    Default

    No prob man, what Dipstick said on the flasher location.
    Please Tell Your Boobs To Quit Staring At My Eyes

Similar Threads

  1. 1998 chevy Suburban turn signal issues... Help!
    By bcreamer23 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 3
    Last Post: 03-11-2012, 10:46 AM
  2. 1990 Suburban Turn signal problem
    By RebTxs in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last Post: 08-29-2010, 01:58 PM
  3. Replies: 0
    Last Post: 07-24-2010, 12:22 PM
  4. 1996 suburban 1500 turn signal issue
    By barryT in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 16
    Last Post: 11-27-2009, 06:33 AM
  5. Flasher/turn signal problems - New relay in need?
    By Springthing in forum Audio, Video & Gadget Tech
    Replies: 6
    Last Post: 12-30-2008, 01:28 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •