GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 LastLast
Results 1 to 10 of 16
  1. #1

    Default Engine Cooling Fan Stays on

    Have a 2006 Chev. Sub. when I shut the engine off and the truck is sitting for a couple of hours the engine cooling fans come on they run until my battery is dead. No engine light on. will shut off when I turn key then back on when I turn key on. Dealer up here doesn't know how to fix. changed relay no help. No messages when they plug in there happy box......lol they checked wires, put new computer in air cooling?? system, really need some help. Thanks

  2. #2

    Default

    why dont you wire in a toogle switch to the hot wire and turn on when you crank it up.

  3. #3

    Default

    Quote Originally Posted by kw70chevy View Post
    why dont you wire in a toogle switch to the hot wire and turn on when you crank it up.
    This will be my last resort if I cannot find the fix.

    ---------- Post added at 08:12 AM ---------- Previous post was at 08:09 AM ----------

    Quote Originally Posted by crustyoldgrizz View Post
    Have a 2006 Chev. Sub. when I shut the engine off and the truck is sitting for a couple of hours the engine cooling fans come on they run until my battery is dead. No engine light on. will shut off when I turn key then back on when I turn key on. Dealer up here doesn't know how to fix. changed relay no help. No messages when they plug in there happy box......lol they checked wires, put new computer in air cooling?? system, really need some help. Thanks
    On my 2001, I have a belt driven radiator fan.

    Do you have electric cooling fan on 2006 burb? If you do, try to find a electrical schematics for engine cooling and we'll try to troubleshoot.
    The fan low and high speeds are controlled by the PCM thru the low and high speed relay coils that are constantly fed with 12V + and through the PCM ground.
    My guess is either you have bad relay contacts or the PCM is providing ground path even with the engine off.

    Oh I noticed, the dealer replaced the relays and PCM. Are the fans still running on low or high speed? At least we can isolate which relay is acting up.
    Last edited by bazar01; 05-22-2012 at 08:05 AM. Reason: added PCM info
    2011 Chevy Silverado LT 4WD 25k miles
    2001 Suburban 2WD, 5.3, V8 176k miles
    1993 964
    1996 318TI

  4. #4

    Default

    Thank you for your reply. I have no mechanical experience. I know it is the low speed fan that is running. If I pull out the Cool/Fan 3 Relay then the fan stops. This is where I am at right now. Thanks Marvin

  5. #5

    Default

    Quote Originally Posted by crustyoldgrizz View Post
    Thank you for your reply. I have no mechanical experience. I know it is the low speed fan that is running. If I pull out the Cool/Fan 3 Relay then the fan stops. This is where I am at right now. Thanks Marvin
    So there are three relays involved? I thought there are only two speeds? Low and fast fan speed.

    Time to search for a schematic.
    2011 Chevy Silverado LT 4WD 25k miles
    2001 Suburban 2WD, 5.3, V8 176k miles
    1993 964
    1996 318TI

  6. #6

    Default

    Wow. I did not know electric cooling fans had ANY speed other than one. Very interesting. I wonder if my '94 has more than one speed.
    1994 Chevy K2500 Silverado, 454 (modified), original owner.
    And other vehicles and toys.

    "...If you can meet with triumph and disaster
    And treat those two imposters just the same;
    ...you'll be a Man, my son!" Rudyard Kipling

  7. #7

    Default

    I'm trying to send the schematic in two parts....hope it comes thru



    Click image for larger version. 

Name:	Capture-33.jpg 
Views:	1401 
Size:	31.8 KB 
ID:	39837Click image for larger version. 

Name:	Capture-34.jpg 
Views:	1394 
Size:	28.8 KB 
ID:	39838

  8. #8

    Default

    Quote Originally Posted by crustyoldgrizz View Post
    I'm trying to send the schematic in two parts....hope it comes thru



    Click image for larger version. 

Name:	Capture-33.jpg 
Views:	1401 
Size:	31.8 KB 
ID:	39837Click image for larger version. 

Name:	Capture-34.jpg 
Views:	1394 
Size:	28.8 KB 
ID:	39838
    This site is great !

    Now I see why there are 3 relays.
    The two on the left are for the high speed operation.
    The one on the far right is for the low speed.
    The low speed relay is triggered by the PCM, then the 12V+ is passed thru the low speed relay normally open contact which closes when energized, to the first fan motor and then to the second fast speed relay normally closed contact, then to the second fan motor then to ground. Low speed operation is due to 12V power being passed on to the two cooling fan motors in series.
    When you turn off the engine, and the fans operate on low speed, pull out the third relay and see if the fans stop.
    2011 Chevy Silverado LT 4WD 25k miles
    2001 Suburban 2WD, 5.3, V8 176k miles
    1993 964
    1996 318TI

  9. #9

    Default

    I shut the engine off the fans are running I pulled the far right (Fan relay 1) the fans stopped running. I then plugged the relay back in and they started back up again. If I leave them on they keep running until battery dead.

  10. #10

    Default

    Quote Originally Posted by crustyoldgrizz View Post
    I shut the engine off the fans are running I pulled the far right (Fan relay 1) the fans stopped running. I then plugged the relay back in and they started back up again. If I leave them on they keep running until battery dead.
    Do you know which relay the dealer replaced? Did they replace all 3 relays?

    The first and the third relays are the same. They both have only one normally open contacts. Try to swap those two relays and see what happens. From the diagram, when you swap those two relays, if the low speed third relay has welded closed contacts, one fan should run in high. Let us know what happens.
    2011 Chevy Silverado LT 4WD 25k miles
    2001 Suburban 2WD, 5.3, V8 176k miles
    1993 964
    1996 318TI

Page 1 of 2 12 LastLast

Similar Threads

  1. 99 suburban a/c stays running with key off
    By Ttorres66@gmail.com in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 0
    Last Post: 10-25-2011, 06:18 PM
  2. Light Stays On?
    By Soupy1957 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 4
    Last Post: 10-31-2010, 06:45 PM
  3. 07 silverado heated seat stays on
    By krmaddock in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 1
    Last Post: 09-02-2010, 08:49 AM
  4. Stereo stays on?
    By 426florez in forum Audio, Video & Gadget Tech
    Replies: 5
    Last Post: 05-23-2010, 03:01 AM
  5. Dome light stays on!
    By Scottydog in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 3
    Last Post: 06-26-2007, 05:16 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •